Project

General

Profile

Bug #7336

syslogd is not running after installing or uninstalling a package with logging (e.g. tinc, haproxy)

Added by Vladimir Lind 4 months ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Logging
Target version:
Start date:
03/02/2017
Due date:
% Done:

0%

Affected version:
2.4
Affected Architecture:

Description

Status page shows no active connections, no info under "Virtual network device statistics, all known nodes, edges and subnets" - having one active connection between two nodes and confirmed connectivity between remote networks.
2.3.3 <-> 2.4

History

#1 Updated by Jim Pingle 4 months ago

  • Subject changed from Tinc pkg doesn't show anything on status page to syslogd is not running after installing or uninstalling a package with logging (e.g. tinc)
  • Category changed from VPN to Logging
  • Assignee deleted (Luiz Otavio O Souza)
  • Affected version changed from 2.3.3 to 2.4

The status output works fine when there is data. That said, after installing or uninstalling the tinc package, syslogd is not running. Saving on the System Logs Settings tab will restart it but that should not be necessary.

I don't see anything in the code for tinc that touches logging other than its package info.xml file contains a <logging> block, so this doesn't appear to be a tinc-specific issue but an issue with the handling of package logs in general.

#2 Updated by Kill Bill 4 months ago

I filed identical bug about haproxy before - Bug #7256. Yeah, nothing package-specific except for having their own logging facility.

#3 Updated by Jim Pingle 4 months ago

  • Subject changed from syslogd is not running after installing or uninstalling a package with logging (e.g. tinc) to syslogd is not running after installing or uninstalling a package with logging (e.g. tinc, haproxy)
  • Status changed from New to Duplicate

How on earth did I miss that one. I'll close this one and update that.

Duplicate of #7256

Also available in: Atom PDF