Project

General

Profile

Bug #7393

Problem with static route when you have Two WAN with same Gateway

Added by Anthony hesnaux over 2 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Very Low
Assignee:
-
Category:
Gateways
Target version:
-
Start date:
03/15/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.2
Affected Architecture:
i386

Description

hello all,
We find a problem on pfsense Nanobsd 2.3.2
Hardware : Motherboard ALIX

we have 2 Wan interface with MPLS Configuration and both WAN have same Gateway.

WAN_ADSL_1(PPPoE0) 10.105.0.10 GW 10.105.0.1 ( default link)
WAN_SDSL_2(PPPoE1) : 10.105.0.11 GW 10.105.0.1

I want add static route "192.168.250.0/24" in order to route all trafic in WAN_SDSL_2(PPPoE1)

When we add static route in web interface Pfsense accept but when we check in diagnostic route menue we have

Internet:
Destination Gateway Flags Netif Expire
default 10.105.0.1 UGS pppoe0
10.105.0.1 link#8 UH pppoe0
10.105.0.10 link#9 UHS lo0
10.105.0.11 link#8 UHS lo0
94.143.87.198/32 10.105.0.1 UGS pppoe0
94.247.160.53/32 10.105.0.1 UGS pppoe0
127.0.0.1 link#7 UH lo0
185.117.37.2/32 10.105.0.1 UGS pppoe0
192.168.3.0/24 link#3 U vr2
192.168.3.5 link#3 UHS lo0
192.168.250.0/24 10.105.0.1 UGS pppoe0

The static route is not routing on good interface. Normaly with my rule 192.168.250.0/24 to pppoe1
Also there is a problem...

We go to CLI for check the configuration :

/root: netstat -nrf inet

Routing tables

Internet:
Destination Gateway Flags Netif Expire
default 10.105.0.1 UGS pppoe0
10.105.0.1 link#8 UH pppoe0
10.105.0.10 link#9 UHS lo0
10.105.0.11 link#8 UHS lo0
94.143.87.198/32 10.105.0.1 UGS pppoe0
94.247.160.53/32 10.105.0.1 UGS pppoe0
127.0.0.1 link#7 UH lo0
185.117.37.2/32 10.105.0.1 UGS pppoe0
192.168.3.0/24 link#3 U vr2
192.168.3.5 link#3 UHS lo0
192.168.250.0/24 10.105.0.1 UGS pppoe0
192.168.251.0/24 10.105.0.1 UGS pppoe0
192.168.252.0/24 10.105.0.1 UGS pppoe0
192.168.253.0/24 10.105.0.1 UGS pppoe0
192.168.254.0/24 link#3 U vr2
192.168.254.254 link#3 UHS lo0

It is the same problem :

192.168.250.0/24 10.105.0.1 UGS pppoe0

Whereas we want this :
192.168.250.0/24 10.105.0.1 UGS pppoe1 !!!!!!

Other information :

root: route -n show 192.168.250/24
route to: 192.168.250.0
destination: 192.168.250.0
mask: 255.255.255.0
gateway: 10.105.0.1
fib: 0 * interface: pppoe0*
flags: <UP,GATEWAY,DONE,STATIC>
recvpipe sendpipe ssthresh rtt,msec mtu weight expire
0 0 0 0 1492 1 0

It's same problem whereas we add static route : 192.168.250.0/24 to pppoe1

For solve this problem I had static route in hard in CLI with :

route add $destination $passerelle -ifp $interface

/root: route add 192.168.250.0/24 10.105.0.1 -ifp pppoe1

test for checking :

/root: netstat -nrf inet
Routing tables

Internet:
Destination Gateway Flags Netif Expire
default 10.105.0.1 UGS pppoe0
10.105.0.1 link#8 UH pppoe0
10.105.0.10 link#9 UHS lo0
10.105.0.11 link#8 UHS lo0
94.143.87.198/32 10.105.0.1 UGS pppoe0
94.247.160.53/32 10.105.0.1 UGS pppoe0
127.0.0.1 link#7 UH lo0
185.117.37.2/32 10.105.0.1 UGS pppoe0
192.168.3.0/24 link#3 U vr2
192.168.3.5 link#3 UHS lo0
192.168.250.0/24 10.105.0.1 UGS pppoe1
192.168.251.0/24 10.105.0.1 UGS pppoe0
192.168.252.0/24 10.105.0.1 UGS pppoe0
192.168.253.0/24 10.105.0.1 UGS pppoe0
192.168.254.0/24 link#3 U vr2
192.168.254.254 link#3 UHS lo0

we have : 192.168.250.0/24 10.105.0.1 UGS pppoe1

I think that when you add static route in pfsense, the system match on gateway of interface and not interface
If both interface have a same gateway, pfense route trafic on défault link also it's not good direction.

when we had static route in CLi we add interface information " -ifp $interface "

---> route add $destination $passerelle -ifp $interface

its best solution but not good for web interface

Can you find a solution ?

thanks

passerelles.PNG (20 KB) passerelles.PNG gateway Anthony hesnaux, 03/15/2017 01:46 PM

History

#1 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Rejected
  • Priority changed from High to Very Low

Having two WANs with the same gateway is not a viable configuration. It's an operating system-level limitation, nothing we can do.

#2 Updated by Anthony hesnaux over 2 years ago

Hello Jim Pingle,
it's not a system-level limitation because when I add static route in CLi : /root: route add 192.168.250.0/24 10.105.0.1 -ifp pppoe1

Pfsense work with freeBSD.

It's work correctly.

Also can accept my request because it's very important.

#3 Updated by Jim Pingle over 2 years ago

Having two interfaces on the same network is not a feature we support, and it is not a valid configuration. The problems you see are expected in that case. We are not going to make special accommodations for configurations that are not valid.

#4 Updated by Michael Kellogg over 2 years ago

wait I thought multi pppoe worked via your own comments and tests I just ordered a second pppoe ?

https://redmine.pfsense.org/issues/6245

#5 Updated by Jim Pingle over 2 years ago

It happens to work, that doesn't make it any more valid than if it were two non-PPPoE lines on the same network, just that the OS doesn't break quite so badly in that case.

#6 Updated by Anthony hesnaux over 2 years ago

Error Jim Pingle,my Both WAN are PPPoE link in IPVPN MPLS but there are a same gateway

I have 1 link PPPoE (ADSL french) for data and 1 link PPPoE ( SDSL french) for VoIP

The ADSL is default link and I add static route to force VOIP to pass by SDSL only ( IPBX and TRUNK SIP in cloud).

ADSL link and SDSL Link have a same gateway.

when you add static route in web interface, this static route work with dateway but no with interface name "pppoe0 or PPPoe1"

it is really bug of pfsense beccause when I add static rout directly in CLI ( console )

I use "route add 192.168.250.0/24 10.105.0.1 -ifp pppoe1" and I define interface with "-ifp pppoe1" ( use by freebsd).

#7 Updated by Jim Pingle over 2 years ago

Yes. And it works by chance, not by design. It's not a configuration we support.

#8 Updated by Anthony hesnaux over 2 years ago

Jim Pingle wrote:

Yes. And it works by chance, not by design. It's not a configuration we support.

No it works corectly beacause is define by an french provider.

If you support multi-wan, You support the possibility of having 2 WAN PPPoE with different gateway or same gateway NO ???

#9 Updated by Jim Pingle over 2 years ago

You can have multiple WANs with different gateways, yes.

You cannot have multiple WANs with the same gateway. If it works at all, it is by accident.

It doesn't matter what the ISP offers, it's not a valid configuration on pfSense.

Also available in: Atom PDF