Project

General

Profile

Todo #7546

d3pie version update

Added by BBcan177 . 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
05/12/2017
Due date:
% Done:

0%


Description

pfSense has d3pie v0.1.6, while the latest version is 0.2.1
https://github.com/benkeen/d3pie

Can this be updated? Not sure if the other /vendor scripts need updating also?

Associated revisions

Revision 47d47846
Added by Steve Beaver 7 months ago

Updated d3.js and d3pie.js to latest versions
Fixed #7546

Revision d5530198
Added by Steve Beaver 7 months ago

Updated d3.js and d3pie.js to latest versions
Fixed #7546

(cherry picked from commit 47d4784602466d723a84bb1af6d313c4ba5a0115)

History

#1 Updated by Steve Beaver 7 months ago

  • Assignee set to Steve Beaver

Checking for compatibility

#2 Updated by Steve Beaver 7 months ago

  • Category set to Web Interface
  • Status changed from New to Resolved
  • Target version set to 2.4.0

Updated as requested

#3 Updated by BBcan177 . 7 months ago

Thanks Steve!

#4 Updated by Pi Ba 7 months ago

Seems the compatibility check failed.

https://forum.pfsense.org/index.php?topic=130533.0

nv.d3.js:93 Uncaught TypeError: nv.dispatch.render_start is not a function
    at Object.render (nv.d3.js:93)
    at Object.nv.addGraph (nv.d3.js:145)
    at String.<anonymous> (traffic-graphs.js:53)
    at Function.each (jquery-1.12.0.min.js?v=1467049863:2)
    at draw_graph (traffic-graphs.js:32)
    at (index):1257
    at HTMLDocument.<anonymous> (pfSense.js?v=1486669873:249)
    at i (jquery-1.12.0.min.js?v=1467049863:2)
    at Object.fireWith [as resolveWith] (jquery-1.12.0.min.js?v=1467049863:2)
    at Function.ready (jquery-1.12.0.min.js?v=1467049863:2)

#5 Updated by Steve Beaver 7 months ago

Reverted

#6 Updated by Michael Kellogg 7 months ago

can this be reverted on master too??

Also available in: Atom PDF