Project

General

Profile

Actions

Bug #7599

closed

System->Update unavailable in WebGUI after connection failure during update

Added by Robert Bear almost 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Upgrade
Target version:
-
Start date:
05/23/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.3_1
Affected Architecture:
amd64

Description

Using the WebGUI to update pfsense from 2.3.3_1 to 2.3.4.
During the update process (downloading packages) the network connection was lost.
- modem disconnected, OpenVPN connection to pfSense remote server dropped, WebGUI stalled in browser.
Re-established connection to network, connected OpenVPN, opened WebGUI to remote pfSense.
Attempted to restart update process, but update page was unavailable in WebGUI.
- Using either System->Update, or Dashboard Update link was always redirected to the Package Update page.
- System Upgrade WebGUI page was not listed - only package update, and install options.
- Reboot of pfsense did not restore the page. No access to System Update in WebGUI.
- Dashboard still reported upgrade was available.

Update was only possible through SSH/Console access.
- Established SSH connection to pfsense.
- Selected Console Upgrade, which continued the package downloads, and completed without further error.

BUG:
- WebGUI disables ability to update pfSense, if the update process is interrupted due to network connection loss.
- Restart of pfSense does not restore WebGUI functionality.
- Upgrade completes without errors if resumed through console.

Actions #1

Updated by Jim Pingle almost 5 years ago

  • Target version changed from 2.3.4-p1 to 2.3.4-p2
Actions #2

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.3.4-p2 to 2.4.2
Actions #3

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.2 to 2.4.3
Actions #4

Updated by Anonymous over 4 years ago

  • Assignee set to Anonymous

Stephen. - Would you please retest and confirm this issue still exists?

Actions #5

Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.3 to 2.4.4
Actions #6

Updated by Jim Pingle almost 4 years ago

  • Status changed from New to Closed
  • Target version deleted (2.4.4)

I can't reproduce this on recent versions. I have download failures regularly for a variety of reasons and all I need to do is refresh the update tab and restart it and it works.

Actions

Also available in: Atom PDF