Project

General

Profile

Actions

Feature #7623

closed

Allow L2TP user passwords to contain special characters

Added by Roland Giesler almost 5 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
L2TP
Target version:
Start date:
06/03/2017
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

In older versions of pfSense, special characters (@#$%^& etc) where allowed in passwords.

Since a while back this has not worked. When a user's password is entered, the form complains that there are invalid characters in the password.

There was a similar problem with other passwords, which has been corrected, so can we have this one fixed too?

Actions #1

Updated by Jim Pingle almost 5 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from L2TP users passwords cannot contain special characters to Allow L2TP user passwords to contain special characters
  • Priority changed from Normal to Low
  • Target version changed from 2.3.4-p1 to 2.4.1

The validation for L2TP user account passwords is the same as it has been since pfSense 2.0 when it was first added. Some other MPD-based service like PPTP may have allowed special characters, but L2TP never has.

It can most likely be changed to work with them as an added feature, but it is not a bug.

Actions #2

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.1 to 2.4.2

Moving target to 2.4.2 as we need 2.4.1 sooner than anticipated.

Actions #3

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.2 to 2.4.3
Actions #4

Updated by Jim Pingle over 4 years ago

  • Target version changed from 2.4.3 to 2.4.4
Actions #5

Updated by Anonymous almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Anonymous
Actions #6

Updated by Anonymous almost 4 years ago

  • % Done changed from 0 to 100
Actions #7

Updated by Anonymous almost 4 years ago

On 2.4.4.a.20180803.1120 (gitsync'd to master), was unable to produce an error when inputting password with special characters.

Actions #8

Updated by Anonymous almost 4 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF