Project

General

Profile

Bug #7641

Multiple reboots without error message

Added by Philipp Haefelfinger almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
-
Start date:
06/12/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4
Affected Architecture:

Description

Hi

I'm running on the 2.4 Beta and I have several unplaned reboots during a normal day. Sometimes it is one within 24 hours, sometimes there are 3-4 reboots.
The sad thing is, that I do not get any crash report. There is no syslog entry. The log is completly normal and I just get a new clean bootup. No dump, no error, no crashreport.

Currently running:
pfSense 2.4.0.b.20170610.1826

Installed packages:
  • AutoConfigBackup
  • Cron
  • nut (network client mode)
  • openvpn-client-export
  • Service_Watchdog
  • zabbix-agent

I'm quite sure that the hardware is ok because the same system was running stable, the memory has no ECC errors and iKVM does not show any issues with temperature or power supply. I can't remember exactly what version I installed when the problems started. But I'm quite sure it is not longer than 3-4 Weeks ago.

Hardware:
  • Asus P9D-E/4L S1150 XEON E3 C224
  • Intel Xeon E3-1231 v3 3.4GHz/8MB
  • 2x Kingston ValueRAM 8GB (1x8) DDR3-1600 ECC CL11
  • Kingston SSDNow V300 60GB
  • Corsair CX Series CX430M - 430 Watt Netzteil

If I can provide some more information or run the system i a diagnostic mode, just tell me and I'll do it.

Beside this issue. Thanks for your great work!

Kind regards

Philipp

History

#1 Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Rejected
  • Target version deleted (2.4.0)

Sudden reboots without crash reports are nearly always hardware, despite the hardware's history.

Post on the forum/list/reddit/etc for help diagnosing the problem and identifying potential solutions before opening a bug report.

#2 Updated by Philipp Haefelfinger almost 2 years ago

Thanks four your hint. I started a research and posted the results in the forum (german: https://forum.pfsense.org/index.php?topic=132074.0 )

I did the following to be sure that it's not a common issue on my hardware:
- cpuburn for 2 hours
- memtest

No test showed any issue or caused the same reboots.

After some trial and error I could spot the cause of the reboots. The reboots are related to the state of the powerd service. As soon as I enable powerd, these reboots happen. With powerd disabled (like I have now) there is no problem and the system runs rock solid as expected.

The intresting part is, that enabling powerd does seem to work for a few hours. I have the highadaptive profile activated. I didn't try other profiles so far.

If I can provide you with some more information, I'll be glad to do that.

For me, I just disabled powerd for the moment.

Thanks for your help and have a nice day.

Kind regards

Philipp

#3 Updated by Jim Pingle almost 2 years ago

That's going to be out of our hands then. Try to reproduce it on a plain FreeBSD system but it's probably an incompatibility between FreeBSD and your BIOS/Hardware. Nothing we can do for that, but if it is in FreeBSD, you can submit a report to them if you can get it to crash on a plain FreeBSD 11 system.

#4 Updated by Philipp Haefelfinger almost 2 years ago

I checked the freebsd bugreports and found a similar issue but with an amd system. I added a comment there so here is the backlink.

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196468

Also available in: Atom PDF