Project

General

Profile

Bug #7726

Many VLANS and php-fpm 100%CPU Hangs web gui

Added by Markus K├Âtter almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
07/26/2017
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

This problem was reported some time ago already:

https://forum.pfsense.org/index.php?topic=102607.0
https://forum.pfsense.org/index.php?topic=101448

In my case, I got about 360 opt Interfaces (vlans & bridges), rendering the list of interfaces as a dashboard widget or "Interfaces -> Assign" is really slow, even though I got decent hardware (>10 cores, >16G RAM).
Slow means "within minutes".
So for me 2.3.x is not usable at all.
I had a look on the code and I think the problem is the logic used to lookup the interface details. A single call to getifaddrs() should be enough for a single request to have all details required for all interfaces, instead it is called rather frequently.

I'd love to give more details - e.g. numbers on calls to getifaddrs(), but I'm missing the toopls required to profile (dtrace?) in pfSense.

History

#1 Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Duplicate
  • Priority changed from Urgent to Normal

Duplicate of #6400

Also available in: Atom PDF