Project

General

Profile

Bug #779

Updating port forwarding associated firewall filter rule to interface group name, leads to incorrect interface labels in NAT port forwarding web interface

Added by Max Mustermann almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
07/31/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Creation of NAT (port forwarding) rules with Interface groups is filed under #701 as feature request.

Though with 2.0BETA4 build 20100731-1322, through the creation of associated filter rules, and updating the firewall rule interface to the group, the associated NAT rule is being updated. Now the interface displays the:
  • 'group name' in:
    1. the port forwarding list view
    2. in the html source code of the interface dropdown box of this rule
  • 'original WAN1' label in:
    1. the user label for the interface dropdown box of this rule
Step-by-step:
  • having 'WAN1', 'WAN2' and 'WAN' as grouping of WAN1+WAN2
  • <firewall_nat.php> can create a rule for WAN1
  • creating an associated filter rule, creates one for WAN1 (= correct)
  • now the associated filter rule can be edited, where interface WAN1 is changed to group WAN <firewall_rules_edit.php?id=1>
  • after saving this, <firewall_nat.php> now displays 'WAN' (= group name) && <firewall_nat_edit.php?id=0> displays 'WAN1' as interface name (!= correct); html source of <firewall_nat_edit.php?id=0> shows: <option selected="" value="wan">WAN1</option>

History

#1 Updated by Chris Buechler almost 10 years ago

  • Status changed from New to Closed

The issue is you're doing something you shouldn't be allowed to do, changing the interface on an associated rule. Opened that as #780.

#2 Updated by Max Mustermann almost 10 years ago

ok

Also available in: Atom PDF