Project

General

Profile

Feature #7794

FRR pkg pfsense no metric-type option in OSPF redistribute section of web-interface

Added by Constantine Kormashev almost 2 years ago. Updated 20 days ago.

Status:
Feedback
Priority:
Very Low
Assignee:
Category:
FRR
Target version:
-
Start date:
08/22/2017
Due date:
% Done:

100%

Estimated time:

Description

There is not metric-type option in OSPF redistribute section of web-interface. By default FRR makes redistribution with route-map without options. But even I use manual route-map for redistribution instead there is no set metric-type option for OSPF IPv4 in web interface of route-map creation.

metrics.png (41.9 KB) metrics.png Constantine Kormashev, 07/01/2019 12:36 AM

History

#1 Updated by Jim Pingle almost 2 years ago

  • Tracker changed from Bug to Feature
  • Project changed from pfSense to pfSense Packages
  • Category changed from Routing to FRR
  • Status changed from New to Assigned
  • Assignee set to Jim Pingle
  • Priority changed from Normal to Very Low
  • Target version deleted (2.4.0)

The OSPF metric option under Route Maps, "Metric" in the drop-down "Metric Action". The options there are the only options offered by FRR for route-maps. It appears FRR is not capable of setting the v4 type there, or perhaps it's the same for v4 and v6 but their documentation only lists 6.

I can look into adding an option to the OSPF GUI but the primary goal initially is feature parity with the Quagga package, which does not have that option either.

#2 Updated by Jim Pingle 21 days ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

This should be possible with FRR pkg version 0.6: https://forum.netgate.com/topic/144572/frr-0-6-coming-big-changes-to-ospf

#3 Updated by Constantine Kormashev 21 days ago

I updated to latest FRR version: 0.5.2 which is based on frr6-6.0.2_1 and there is still not External type metrics settings for OSPF, only for OSPFv3 (IPv6) in route-map section:

#4 Updated by Jim Pingle 20 days ago

  • Status changed from Assigned to Feedback

0.5.2 is not the latest version. The latest version is 0.6, which is what I said in my comment. FRR pkg version 0.6 is only now available on 2.5.0 snapshots. Use it there and try again.

Also available in: Atom PDF