Project

General

Profile

Actions

Feature #7847

closed

USB NIC not loading (TP-Link UE300 RTL8153)

Added by J L about 4 years ago. Updated about 4 years ago.

Status:
Needs Patch
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
09/06/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:

Description

The TP-Link UE300 usb nic is not loading an interface. The device is well supported on Apple OSX, Linux, Microsoft Windows.

See this page for validation of the chipset http://www.tp-link.com/en/products/details/cat-5062_UE300.html#specifications

Chipset= RTL8153

Two year old notes exit on this chipset but i could not understand how to relate to them https://redmine.pfsense.org/projects/pfsense/search?utf8=%E2%9C%93&q=RTL8153

Actions #1

Updated by J L about 4 years ago

Please, let me know if there's anything i can do to advance this

Actions #2

Updated by J L about 4 years ago

Just found https://lists.freebsd.org/pipermail/freebsd-net/2015-June/042396.html

usbconfig -d ugen0.2 set_config 1

assigned a network interface, can this be considered as a request to have this automated ?

Actions #3

Updated by Jim Pingle about 4 years ago

  • Tracker changed from Bug to Feature
  • Status changed from New to Needs Patch
  • Target version changed from 2.3.4-p2 to Future
Actions #4

Updated by Kill Bill about 4 years ago

J L wrote:

can this be considered as a request to have this automated ?

Stick it as earlyshellcmd to Shellcmd package? (No, I have no interest in providing a patch for USB NICs.)

Actions

Also available in: Atom PDF