Project

General

Profile

Actions

Bug #8017

closed

Changing VLAN assignments breaks parent LAGG interface

Added by Samuel Kadolph about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
10/26/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.1
Affected Architecture:

Description

I updated to 2.4.1 tonight forgetting about the PPPoE over VLAN issue so I started changing my WAN interface and then I lost all connectivity. Thankfully I have a management network and I could get into the router and poke around. I discovered that my lagg0 interface's ethernet address was set to 00:00:00:00:00:00. Any VLAN assignment to the LAGG seemed to trigger the ethernet address to change to 00:00:00:00:00:00. Manually setting the ethernet address back to what it's supposed to be or changing the LAGG members fixed the issue (once you flush your arp table).

This is how it looks when it's working properly:

[2.4.1-RELEASE][samuelkadolph@gw1.ottawa.samuelkadolph.com]/home/samuelkadolph: ifconfig igb1
igb1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6500bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:30:18:cb:f9:bb
    hwaddr 00:30:18:cb:f9:ba
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
[2.4.1-RELEASE][samuelkadolph@gw1.ottawa.samuelkadolph.com]/home/samuelkadolph: ifconfig igb2
igb2: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6500bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:30:18:cb:f9:bb
    hwaddr 00:30:18:cb:f9:bb
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
[2.4.1-RELEASE][samuelkadolph@gw1.ottawa.samuelkadolph.com]/home/samuelkadolph: ifconfig lagg0
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6500bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:30:18:cb:f9:bb
    inet6 fe80::230:18ff:fecb:f9ba%lagg0 prefixlen 64 scopeid 0xd
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: active
    groups: lagg
    laggproto lacp lagghash l2,l3,l4
    laggport: igb1 flags=0<>
    laggport: igb2 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>

And when it's broken:

[2.4.1-RELEASE][samuelkadolph@gw1.ottawa.samuelkadolph.com]/home/samuelkadolph: ifconfig lagg0
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6500bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:00:00:00:00:00
    inet6 fe80::230:18ff:fecb:f9ba%lagg0 prefixlen 64 scopeid 0xd
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: active
    groups: lagg
    laggproto lacp lagghash l2,l3,l4
    laggport: igb1 flags=0<>
    laggport: igb2 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>

And manually setting the ethernet address fixes the issue:

[2.4.1-RELEASE][samuelkadolph@gw1.ottawa.samuelkadolph.com]/home/samuelkadolph: sudo ifconfig lagg0 ether 00:30:18:cb:f9:ba
[2.4.1-RELEASE][samuelkadolph@gw1.ottawa.samuelkadolph.com]/home/samuelkadolph: ifconfig lagg0
lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=6500bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:30:18:cb:f9:ba
    inet6 fe80::230:18ff:fecb:f9ba%lagg0 prefixlen 64 scopeid 0xd
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: no carrier
    groups: lagg
    laggproto lacp lagghash l2,l3,l4
    laggport: igb1 flags=0<>
    laggport: igb2 flags=0<>
Actions #1

Updated by Jim Pingle about 4 years ago

  • Status changed from New to Duplicate

Duplicate of #7928

Actions

Also available in: Atom PDF