Project

General

Profile

Bug #8235

The browser must support cookies to login

Added by Scott Phillips about 2 years ago. Updated 4 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
12/23/2017
Due date:
12/23/2017
% Done:

0%

Estimated time:
6.00 h
Affected Version:
Affected Architecture:

Description

I updated pfsense to use secure socket that utilizes port 443 to login as the adminstrator. Upon attempting to login to pfsense post change, I get "The browser must support cookies to login". I allow cookies within the browser, however I cannot get past this message. I've rebooted the browser and have I've attempted this in firefox, safari, chrome to NO avail. Hoping someone can help me out.

firefox_2017-12-23_18-48-12.jpg (265 KB) firefox_2017-12-23_18-48-12.jpg Phil Keep, 12/23/2017 11:57 AM

History

#1 Updated by Phil Keep about 2 years ago

Hello Scott,
Your symptoms are quite strange. Cookies are working in general since years in PFsense.
This should be something related to your browsers.
1) Could you precise which PFsense version you are using (and also one detailed version
from your client browser and underlying OS).
Maybe you have a kind of (client) OS filter active?
2) Look at the annexed screenshot: Firefox 57.0.2 on Win7 accessing PFsense 2.4.2 amd64.
All works fine with HTTPS and cookies.
Cheers Phil.

#2 Updated by Gabriel Paniagua Castro over 1 year ago

Scott Phillips wrote:

I updated pfsense to use secure socket that utilizes port 443 to login as the adminstrator. Upon attempting to login to pfsense post change, I get "The browser must support cookies to login". I allow cookies within the browser, however I cannot get past this message. I've rebooted the browser and have I've attempted this in firefox, safari, chrome to NO avail. Hoping someone can help me out.

I'm having this problem after I restored the web_gui to http from the console using assign IP address to interface. I'm unable to access my pfsense from any browser.

#3 Updated by Jim Pingle over 1 year ago

Does the same thing happen with an incognito/private mode browser session that has never visited that firewall before?

When HTTPS is enabled, pfSense sends a secure cookie, and if the browser stores that, it may refuse to process that cookie over HTTP in the future. You may have to manually delete cookies for the firewall host from your browser to continue.

I'm not sure there is anything the firewall itself can do about that. Similar issues can happen with cached HSTS settings.

#4 Updated by Greg Toombs 10 months ago

I'm getting affected by this as well, under similar circumstances.

Jim Pingle wrote:

Does the same thing happen with an incognito/private mode browser session that has never visited that firewall before?

Yes. Incognito mode, as well as using a different browser that's never seen the URL before, pops up the same message.

#5 Updated by Bob Frank 7 months ago

I have the same problem under different circumstances. I bought a new firewall to upgrade hardware. Pfsense web ui worked fine but then I restored my config from the old firewall via the webui. The old firewall is setup https to port 8888. After the restore, on the new firewall I get the error "The browser must support cookies to login."

#6 Updated by Jim Pingle 7 months ago

  • Category set to Web Interface
  • Status changed from New to Not a Bug

This appears to be a local problem with browser caching and is likely from HSTS or similar. You'll have to clear the cache and probably manually delete cookies if you change from HTTPS to HTTP. That's all up to your browser, though.

Also available in: Atom PDF