Project

General

Profile

Bug #8333

Dynamic DNS updates may fail when using a gateway group as the interface when the default route is down

Added by Jim Pingle over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
Start date:
02/16/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

When the interface of a Dynamic DNS entry is set to a gateway group and the default route is down, the update may fail.

PR at https://github.com/pfsense/pfsense/pull/3905

History

#1 Updated by Constantine Kormashev over 1 year ago

Well. I setup new one 2440 with latest 2.4.3 And 2 GW with Active/Passive GW group. Looks like DDNS should work because I see entries in system log. But we have only one external IP one stayed the same after main GW went to down


Mar 13 10:47:03 php-fpm 42590 /widgets/widgets/dyn_dns_status.widget.php: Default gateway down setting WAN2GW as default!

Mar 13 10:46:57 php-fpm 40884 /widgets/widgets/dyn_dns_status.widget.php: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: phpDynDNS (ubut.ddns.net): No change in my IP address and/or 25 days has not passed. Not updating dynamic DNS entry.

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Dynamic Dns (ubut.ddns.net): Current WAN IP: 91.212.168.20 Cached IP: 91.212.168.20

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Dynamic DNS noip-free (ubut.ddns.net): 91.212.168.20 extracted from checkip.dyndns.org

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Dynamic DNS (ubut.ddns.net): running get_failover_interface for GWGR. found igb2

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Dynamic DNS noip-free (ubut.ddns.net): 91.212.168.20 extracted from checkip.dyndns.org

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 333 /rc.filter_configure_sync: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Default gateway down setting WAN2GW as default!

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Dynamic DNS: updatedns() starting

Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: MONITOR: WAN_DHCP is down, omitting from routing group GWGR

172.21.41.1|172.21.41.158|WAN_DHCP|0.268ms|0.052ms|23%|down
Mar 13 10:46:56 php-fpm 334 /rc.dyndns.update: Default gateway down setting WAN2GW as default!
Mar 13 10:46:55 check_reload_status Reloading filter
Mar 13 10:46:55 check_reload_status Restarting OpenVPN tunnels/interfaces
Mar 13 10:46:55 check_reload_status Restarting ipsec tunnels
Mar 13 10:46:55 check_reload_status updating dyndns WAN_DHCP
Mar 13 10:46:55 rc.gateway_alarm 84881 >>> Gateway alarm: WAN_DHCP (Addr:172.21.41.1 Alarm:1 RTT:268ms RTTsd:54ms Loss:21%)

#2 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Tested and working.

#3 Updated by Steven Perreau about 1 year ago

I was looking forward t0 running 2.4.3 to see if dynamic DNS would finally work.

My latest testing on 2.4.3 is ddns still does NOT work.

I wonder if the issue is:

My gateway group consists of 2 CARP entries, WAN1 carp and WAN2 carp and I wonder wonder wonder if that's why ddns just never updates!

However, as it stands today, 2 pfsense in an HA cluster with multi WAN (WAN1 and WAN2) - on failing WAN1, ddns entry goes RED on the status pages but never actually updates and goes green with the WAN2 carp address.

Also available in: Atom PDF