Project

General

Profile

Actions

Bug #8347

closed

NAT with Multiple OpenVPN interfaces

Added by Daniel Kucera about 4 years ago. Updated about 4 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
02/26/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

We have router with 2 OpenVPN instances:
  • server for connecting clients
  • client to remote location which connects to remote OpenVPN server and gets dynamic IP

I want to setup outbond NAT on connections going to remote location. So I setup NAT like on attached picture.

But the issue is that only each other connection is correctly NAT-ed (see attached packet capture).
When I disable server instance, all connections all correctly NAT-ed.


Files

Actions #1

Updated by Jim Pingle about 4 years ago

  • Status changed from New to Not a Bug

Config issue. You need to assign the interfaces so the NAT rules only apply to the one interface you intend, not all OpenVPN interfaces. Post on the forum, mailing list, or pfSense subreddit for assistance.

Actions

Also available in: Atom PDF