Project

General

Profile

Bug #8368

Cannot log into webConfigurator from Firefox/Linux after fresh install

Added by Michael von Glasow over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
03/13/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.2
Affected Architecture:

Description

To reproduce:

  • Install pfSense 2.4.2 from scratch.
  • Assign interfaces, configure an IP address and DHCP server for the LAN interface.
  • Open webConfigurator from a PC on the LAN network (via HTTP and the IP address).

Behavior observed:

  • The login page appears.
  • When I enter the default credentials and click Sign In, the text boxes are cleared and I get the same login page again; no error message is displayed.
  • The system beeps and reports a successful login on the console.

Expected behavior:

  • webConfigurator loading after supplying correct credentials.

System configuration:

  • Server side: pfSense 2.4.2, AMD 64, serial console, installed via USB Memstick installer on ALIX hardware
  • Client side: Ubuntu MATE 16.04, Firefox 58.0.2

Additional information:

  • When I enter an incorrect password, the login page displays Username or Password incorrect in the top bar; this does not happen with the correct credentials. Also, login attempts with incorrect credentials are logged as such on the console.
  • I was able to log into webConfigurator from a Windows 7 PC, also running Firefox 58.0.2.
  • I then restored the configuration from my previous 2.2.6 setup, which contains SSL certs and blocks HTTP access to webConfigurator. After that, login from the Linux machine worked as well.

History

#1 Updated by Michael von Glasow over 1 year ago

Since this is a live system (on which I rely for Internet access), I cannot easily reproduce the issue with the same hardware. If need be, however, I may be able to run tests with a VM.

#2 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Rejected

There is no such problem with pfSense itself. That is a client side issue.

#3 Updated by Michael von Glasow over 1 year ago

I would agree about this being a client side issue if logins were to fail for every web site I visit. However, this is not the case—pfSense so far has been the only place which had this issue.

Most likely the cause lies somewhere in the interaction between the two systems. Maybe the response from pfSense is botched and other browsers are just more tolerant of it, or maybe it is indeed a bug in the browser. Or something in between—we just don’t know until we investigate.

Would it help if I filed a bug for Firefox?

#4 Updated by Jim Pingle over 1 year ago

Until it's proven to be a bug on pfSense (after discussion on the forum, subreddit, etc) then it doesn't belong here. It's not clear if it's a Firefox issue, specifically, either.

We use lots of Linux desktops and VMs internally and use new installs constantly for testing. If it was broken in this way, there would be many, many instances of failure that we could reproduce. It is undoubtedly something local to you, but you need to discuss it in a discussion platform to narrow down possible causes.

Also available in: Atom PDF