Project

General

Profile

Bug #8485

pkg_mgr_install.php: Arbitrary files can be read by an authenticated user via logfilename sent in POST

Added by Jim Pingle 30 days ago. Updated 12 days ago.

Status:
Resolved
Priority:
Very High
Assignee:
Category:
Package System
Target version:
Start date:
04/26/2018
Due date:
% Done:

100%

Affected Version:
2.4.x
Affected Architecture:
All

Description

logfilename is taken from POST and can be used to read arbitrary text files from the firewall.

The logfilename parameter will need some validation, such as a whitelist, basename & locked to one dir, or to use a keyword instead of a filename directly.

Associated revisions

Revision c29a1fe9
Added by Steve Beaver 29 days ago

Fixed #8485 by POSTing fixed string and looking up the required file name

Revision 48f8b5ad
Added by Steve Beaver 25 days ago

Fixed #8485 by POSTing fixed string and looking up the required file name

(cherry picked from commit c29a1fe90f89c1ae392df2ef2092207e282ddc37)

Revision 9d918214
Added by Steve Beaver 25 days ago

Fixed #8485 by POSTing fixed string and looking up the required file name

(cherry picked from commit c29a1fe90f89c1ae392df2ef2092207e282ddc37)

Revision 8d7458f6
Added by Steve Beaver 25 days ago

Fixed #8485 by POSTing fixed string and looking up the required file name

(cherry picked from commit c29a1fe90f89c1ae392df2ef2092207e282ddc37)

History

#1 Updated by Steve Beaver 29 days ago

  • Assignee changed from Renato Botelho to Steve Beaver

#2 Updated by Steve Beaver 29 days ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle 29 days ago

  • Status changed from Feedback to Resolved

Unable to reproduce with the fix applied. Looks good to me.

#4 Updated by Jim Pingle 23 days ago

  • Target version changed from 2.4.4 to 2.4.3_1

#5 Updated by Jim Pingle 12 days ago

  • Private changed from Yes to No

Also available in: Atom PDF