Project

General

Profile

Bug #8515

ts wizard syntax error (as of 2.4.4.a.20180514.0905)

Added by ROB VANHOOREN almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
05/14/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

gui> fw> shaper> wizard> dedicated>

result?

Parse error: syntax error, unexpected 'else' (T_ELSE) in /usr/local/www/wizards/traffic_shaper_wizard_dedicated.inc on line 781

thanks,
R.

floating-rules.png (63 KB) floating-rules.png Floating rules James Dekker, 05/19/2018 02:11 PM
Reload-status.log (2.55 KB) Reload-status.log Reload status - after completing the wizard James Dekker, 05/19/2018 02:12 PM

Associated revisions

Revision 962c8cce (diff)
Added by Steve Beaver almost 2 years ago

Fixed #8515 (Syntax error)

Revision 826b11a3 (diff)
Added by Renato Botelho almost 2 years ago

Fixed #8515 (Syntax error)

Revision 41160d19 (diff)
Added by Stephen Jones over 1 year ago

Fixed #8515 Queues should now be added either through manually creating them or through the wizard

Revision 5ffeceb6 (diff)
Added by Stephen Jones over 1 year ago

Fixed #8515 fixed error in queue defintion where it would repeat

It should now create a new definition for each queue. Queues should
now show up under status > queues.

History

#1 Updated by Steve Beaver almost 2 years ago

  • Status changed from New to Feedback

Fixed in next snapshot. Thanks!

#2 Updated by Steve Beaver almost 2 years ago

  • % Done changed from 0 to 100

#3 Updated by ROB VANHOOREN almost 2 years ago

whoops, that broke something else.

wizard> (steps) -> apply ... makes the floating rules but does not create any queues.

[15-May-2018 16:08:50 America/Toronto] PHP Warning: Invalid argument supplied for foreach() in /usr/local/www/wizards/traffic_shaper_wizard_dedicated.inc on line 1555

#4 Updated by James Dekker almost 2 years ago

No "PHP Warning: Invalid argument supplied for foreach() in /usr/local/www/wizards/traffic_shaper_wizard_dedicated.inc on line 1555" error on 2.4.4.a.20180518.1741 CE sync'd to master, but when the wizard completes, it leaves shapers in the config.xml but there are no queues at Status > Queues, although the floating rules and queues seem to have been created successfully.

#5 Updated by James Dekker over 1 year ago

Retested Traffic Shaping Wizards on 2.4.4.a.20180609.0944 and got the following alerts in the GUI

Filter Reload

There were error(s) loading the rules: /tmp/rules.debug:40: errors in queue definition - The line in question reads [40]: queue qLink on igb1 priority 2 qlimit 500 priq ( ecn , default )
2018-06-09 20:26:33
There were error(s) loading the rules: /tmp/rules.debug:40: errors in queue definition - The line in question reads [40]: queue qLink on igb1 priority 2 qlimit 500 priq ( ecn , default )
2018-06-09 20:27:24

Plus no queues under Status > Queues, although it did seem to create the floating firewall rule and put traffic shaping in the config.

#6 Updated by Steve Beaver over 1 year ago

  • Assignee set to Anonymous

#7 Updated by James Dekker over 1 year ago

On 2.4.4.a.20180705.0032 the wizard completes without error and the queues show up under Status > Queues

#8 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF