Project

General

Profile

Feature #8548

User creation is not logged correctly

Added by Ivor Kreso over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
User Manager / Privileges
Target version:
Start date:
06/04/2018
Due date:
% Done:

100%

Estimated time:

Description

Two issues:

1. Creating a non-admin user via WebGUI does not show in log.

2. Creating a new user in admin group shows in log as an error and instead of username nextuserid is shown.

/system_usermanager.php: The command '/usr/sbin/pw groupmod -l 'admins' -g '1999' -M '0,2020' 2>&1' returned exit code '67', the output was 'pw: user `2020' does not exist'

See also PCI DSS requirement 10.2.5

Associated revisions

Revision 3fa6d462 (diff)
Added by Jim Pingle over 1 year ago

Fix up user/group management save message descriptions, add logging for same. Fixes #8548

Revision 513662e8 (diff)
Added by Jim Pingle over 1 year ago

Fix up user/group management save message descriptions, add logging for same. Fixes #8548

(cherry picked from commit 3fa6d46229757e2316120a7160a806bb7d28a8ed)

History

#1 Updated by Jim Pingle over 1 year ago

  • Tracker changed from Bug to Feature

#1 Adding logging is a feature request, not a bug.
#2 is not a logging issue, it's a bug and it needs its own ticket.

It's not easily possible to separate logging of create/edit/delete for admin users since any group can have "admin" privileges not just the admins group, and in terms of firewall privileges it's vague on which are or are not considered "admin" privileges.

We can at least add consistent logging for various user/group operations.

#2 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle over 1 year ago

Group error bug moved to #8553

#4 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF