Project

General

Profile

Bug #8592

Can't "Register DHCP leases in the DNS Resolver" when only using DHCPv6

Added by Isaac McDonald 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DNS Resolver
Target version:
Start date:
06/22/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

Attempts to enable "Register DHCP leases in the DNS Resolver" in the "DNS Resolver" module fail when only DHCPv6 is enabled.

The error is:

DHCP Server must be enabled for DHCP Registration to work in DNS Resolver.

Steps to reproduce:

  1. Enable and configure an instance of DHCPv6 in "Services ---> DHCPv6 Server & RA"
  2. Disable any instances of DHCP in "Services ---> DHCP Server"
  3. Navigate to "Services ---> DNS Resolver" and enable "Register DHCP leases in the DNS Resolver" then click save
  4. Note the error "DHCP Server must be enabled for DHCP Registration to work in DNS Resolver."

Associated revisions

Revision e7d76457 (diff)
Added by Isaac McDonald 11 months ago

Redmine #8592: Clarify DHCP hostname registration

History

#1 Updated by Jim Pingle 11 months ago

  • Status changed from New to Not a Bug

DHCPv6 does not support registering hostnames, so this is working as expected. Only IPv4 DHCP is capable of pulling hostnames from leases into DNS.

#2 Updated by Isaac McDonald 11 months ago

If that's the case, the description for the option should be changed to reflect the fact that it only applies to IPv4 addresses.

The description currently reads:

"If this option is set, then machines that specify their hostname when requesting a DHCP lease will be registered in the DNS Resolver, so that their name can be resolved. The domain in System > General Setup should also be set to the proper value."

A more accurate description is:

"If this option is set, then machines that specify their hostname when requesting an IPv4 DHCP lease, will be registered in the DNS Resolver so that their name can be resolved. The domain in System > General Setup should also be set to the proper value."

#3 Updated by Jim Pingle 11 months ago

Granted it could be more clear, but DHCP is always IPv4, it does not refer to both. For IPv6 support, things are labeled DHCPv6 since it's a different protocol.

#5 Updated by Jim Pingle 11 months ago

  • Status changed from Not a Bug to Resolved
  • Target version set to 2.4.4
  • Affected Version set to All
  • Affected Architecture set to All

Also available in: Atom PDF