Project

General

Profile

Bug #8651

another php error (broke stable pfBng)

Added by ROB VANHOOREN 8 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
-
Start date:
07/15/2018
Due date:
07/17/2018
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

latest pfS (2.4.4.a.20180715.1209) broke stable pfBng (2.1.2_5)

thousands of
PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 3445

thanks,
R.

Crash report begins. Anonymous machine information:

amd64
11.2-RELEASE
FreeBSD 11.2-RELEASE #11 af4526707ed(RELENG_2_4_4): Sun Jul 15 12:10:30 EDT 2018 root@buildbot3:/builder/crossbuild-ce-master/obj/amd64/FWJoMRHc/builder/crossbuild-ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[16-Jul-2018 00:15:53 America/Toronto] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 3445

[... repeats thousands of times ...]

History

#1 Updated by Jim Thompson 8 months ago

  • Project changed from pfSense to pfSense Packages
  • Category set to pfBlockerNG

#2 Updated by ROB VANHOOREN 8 months ago

latest pfB (2.1.4_6) appears to have moved this error down 5 lines in the code, to 3450.

repeats in the thousands (enough for crashreporter.php's 512MB limit PHP 4096-byte malloc to fail)

as of latest pfS 2.4.4.a.20180725.0621

thanks,

R.

Crash report begins. Anonymous machine information:

amd64
11.2-RELEASE
FreeBSD 11.2-RELEASE #31 cd0e4c8cf25(RELENG_2_4_4): Wed Jul 25 06:22:26 EDT 2018 root@buildbot3:/builder/crossbuild-ce-master/obj/amd64/FWJoMRHc/builder/crossbuild-ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[25-Jul-2018 10:15:33 America/Toronto] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 3450
[25-Jul-2018 10:15:33 America/Toronto] PHP Warning: count(): Parameter must be an array or an object that implements Countable in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 3450

#3 Updated by Anonymous 8 months ago

  • Assignee set to Anonymous

#4 Updated by Anonymous 8 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Fix pushed: e907705240bf2f51e2e99b09e911fc149162b465

#5 Updated by BBcan177 . 7 months ago

This should be fixed in the latest pfBlockerNG version.

#6 Updated by James Dekker about 2 months ago

  • Status changed from Feedback to Resolved

Not able to reproduce this behavior on 2.4.5.a.20190201.0810 with pfBlockerNG 2.1.4_16.

Also available in: Atom PDF