Project

General

Profile

Bug #8653

Spurious HA XMLRPC Sync Error after move to PHP7

Added by Jim Pingle over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
XMLRPC
Target version:
Start date:
07/16/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

After moving to PHP7, an HA pair logs an XMLRPC error and files a notice even though the synchronization appears to have succeeded.

Primary logs an XMLRPC error:

Jul 16 11:22:53     php-fpm     983     /rc.filter_synchronize: Beginning XMLRPC sync data to https://10.11.2.3:443/xmlrpc.php.
Jul 16 11:22:53     php-fpm     983     /rc.filter_synchronize: XMLRPC reload data success with https://10.11.2.3:443/xmlrpc.php (pfsense.host_firmware_version).
Jul 16 11:22:53     php-fpm     983     /rc.filter_synchronize: XMLRPC versioncheck: 18.4 -- 18.4
Jul 16 11:22:53     php-fpm     983     /rc.filter_synchronize: Beginning XMLRPC sync data to https://10.11.2.3:443/xmlrpc.php.
Jul 16 11:22:54     php-fpm     983     /rc.filter_synchronize: Exception calling XMLRPC method restore_config_section # String could not be parsed as XML
Jul 16 11:22:54     php-fpm     983     /rc.filter_synchronize: New alert found: Exception calling XMLRPC method restore_config_section # String could not be parsed as XML
Jul 16 11:22:54     php-fpm     983     /rc.filter_synchronize: Beginning XMLRPC sync data to https://10.11.2.3:443/xmlrpc.php.
Jul 16 11:22:55     php-fpm     983     /rc.filter_synchronize: Exception calling XMLRPC method restore_config_section # String could not be parsed as XML
Jul 16 11:22:55     php-fpm     983     /rc.filter_synchronize: New alert found: Exception calling XMLRPC method restore_config_section # String could not be parsed as XML 

Secondary logs no errors:

Jul 16 11:22:54     check_reload_status         Syncing firewall
Jul 16 11:22:54     check_reload_status         Reloading filter
Jul 16 11:22:54     check_reload_status         Syncing firewall
Jul 16 11:22:55     check_reload_status         Reloading filter

And in the config history, it appears the XMLRPC sync completed successfully:

7/16/18 11:22:54     18.4     108 KiB     (system)@10.11.2.2: Merged in config (dnshaper, staticroutes, gateways, virtualip, system, aliases, ca, cert, crl, dhcpd, filter, ipsec, load_balancer, nat, openvpn, schedules, unbound, wol sections) from XMLRPC client.
7/16/18 11:22:54     18.4     108 KiB     (system)@10.11.2.2: Merged in config (dnshaper, staticroutes, gateways, virtualip, system, aliases, ca, cert, crl, dhcpd, filter, ipsec, load_balancer, nat, openvpn, schedules, unbound, wol sections) from XMLRPC client.

History

#1 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback

I can't reproduce this on current snapshots after fixing some PHP errors. It's possible this was from the secondary encountering a PHP error during the sync.

The fixes were just pushed and not directly related to this ticket. See b2c97edeceb3d32696767c6d6340e57839e67405 and b1e7a0b0c83dafb19dd69b6b05947a8aa4336569 but any similar error could have triggered the situation.

#2 Updated by Constantine Kormashev over 1 year ago

do not observe the issue on latest, different settings FW, NAT, VIP synced without errors

#3 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved
  • Assignee set to Jim Pingle
  • % Done changed from 0 to 100

Also available in: Atom PDF