Project

General

Profile

Bug #8673

Bridge interface php error

Added by James Dekker 11 months ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
07/20/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

On 2.4.4.a.20180720.1418, go to Interfaces > Assignments, then to Bridges. Click Add and select interfaces to make a bridge, click Save. Then delete the bridge. Once it's deleted, click Add. The following error will appear:

Warning: Illegal string offset 'bridged' in /usr/local/www/interfaces_bridge_edit.php on line 32 Warning: Illegal string offset 'bridged' in /usr/local/www/interfaces_bridge_edit.php on line 59 Fatal error: Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/interfaces_bridge_edit.php:59 Stack trace: #0 {main} thrown in /usr/local/www/interfaces_bridge_edit.php on line 59 PHP ERROR: Type: 1, File: /usr/local/www/interfaces_bridge_edit.php, Line: 59, Message: Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/interfaces_bridge_edit.php:59 Stack trace: #0 {main} thrown

Associated revisions

History

#1 Updated by James Dekker 11 months ago

The following shows up in a crash report:

Crash report begins.  Anonymous machine information:

arm
11.2-RELEASE
FreeBSD 11.2-RELEASE #18 adb97d79427(factory-RELENG_2_4_4): Fri Jul 20 14:45:49 EDT 2018     root@buildbot3:/builder/crossbuild-master/obj/armv6/C5dYt69Q/arm.armv6/builder/crossbuild-master/pfSense/tmp/FreeBSD-src/sys/pfSense-uFW

Crash report details:

PHP Errors:
[20-Jul-2018 22:58:14 Etc/UTC] PHP Warning:  exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712
[20-Jul-2018 22:58:14 Etc/UTC] PHP Warning:  exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712
[20-Jul-2018 22:58:59 Etc/UTC] PHP Warning:  Illegal string offset 'bridged' in /usr/local/www/interfaces_bridge_edit.php on line 32
[20-Jul-2018 22:58:59 Etc/UTC] PHP Warning:  Illegal string offset 'bridged' in /usr/local/www/interfaces_bridge_edit.php on line 59
[20-Jul-2018 22:58:59 Etc/UTC] PHP Fatal error:  Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/interfaces_bridge_edit.php:59
Stack trace:
#0 {main}
  thrown in /usr/local/www/interfaces_bridge_edit.php on line 59

No FreeBSD crash data found.

#2 Updated by Jim Thompson 11 months ago

  • Category set to Web Interface
  • Assignee set to Steve Beaver
  • Target version set to 2.4.4

#3 Updated by Steve Beaver 11 months ago

  • Status changed from New to This Sprint

#4 Updated by Steve Beaver 11 months ago

  • Status changed from This Sprint to In Progress

#5 Updated by Steve Beaver 11 months ago

  • Status changed from In Progress to Feedback

#6 Updated by Steve Beaver 11 months ago

  • % Done changed from 0 to 100

#7 Updated by James Dekker 11 months ago

On 2.4.4.a.20180802.1755 (gitsync'd to master), cannot reproduce the issue.

However, a crash is still being generated (see below)

Crash report begins.  Anonymous machine information:

amd64
11.2-RELEASE
FreeBSD 11.2-RELEASE #47 cd0e4c8cf25(RELENG_2_4_4): Thu Aug  2 17:56:25 EDT 2018     root@buildbot3:/builder/crossbuild-ce-master/obj/amd64/FWJoMRHc/builder/crossbuild-ce-master/pfSense/tmp/FreeBSD-src/sys/pfSense

Crash report details:

PHP Errors:
[03-Aug-2018 01:21:30 Etc/UTC] PHP Warning:  exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712
[03-Aug-2018 01:21:30 Etc/UTC] PHP Warning:  exec(): NULL byte detected. Possible attack in /etc/inc/util.inc on line 1712

No FreeBSD crash data found.

#8 Updated by Steve Beaver 11 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF