Project

General

Profile

Bug #873

deinstall does not unset package <menu> and <service> tags from /conf/config.xml

Added by robert zelaya almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Package System
Target version:
Start date:
09/03/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

Issue:

deinstall does not unset package <menu> and <service> tags from /conf/config.xml

Cause:

"require_once("config.inc");" in the packagename.inc file.

Temp Solution:

remove "require_once("config.inc");"

Notes:

The cause might be a name conflict between config.inc or pkg-utils.inc.

Associated revisions

Revision b2a66231 (diff)
Added by Ermal Luçi almost 9 years ago

Ticket #873. Call write_config() before including file to avoid loosing already done modifications. While here do some code cleanup and formating to make it more readble.

History

#1 Updated by Chris Buechler almost 9 years ago

  • Category set to Package System
  • Target version set to 2.0

#2 Updated by Ermal Luçi almost 9 years ago

  • Status changed from New to Feedback

#3 Updated by robert zelaya almost 9 years ago

Fixed; Ermal fixed my issue with his update sept, 07 2010.

#4 Updated by robert zelaya almost 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF