Project

General

Profile

Bug #8749

OSPF6 nssa not working

Added by Marc Planquart about 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
FRR
Target version:
-
Start date:
08/04/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.3_1
Affected Architecture:

Description

Checked with version 2.4.3-1 and the latest 2.4.4!

In ospf6d.conf:
router ospf6
router-id 62.48.65.10
interface em0 area 0.0.4.175
area 0.0.4.175 nssa
redistribute connected route-map DNR6
...

In vtysh
!
router ospf6
router-id 62.48.65.10
redistribute connected route-map DNR6
area 0.0.4.175 range 2a00:e68:1c:2199::/64 cost 1
area 0.0.4.175 export-list dnr6-list
interface em0 area 0.0.4.175

In other words, the nssa directive for the area is not set!
This is confirmed using tcpdump:
The Hello packet has the E bit set instead of N

Thanks,
Marc.

Screen Shot 2018-08-04 at 8.25.25 PM.png (74.5 KB) Screen Shot 2018-08-04 at 8.25.25 PM.png E bit set instead of N Marc Planquart, 08/04/2018 07:26 PM

History

#1 Updated by Marc Planquart about 1 year ago

The directive is not set in vtysh because the nssa directive is not recognized. Only normal areas and stub areas seem to be available. Below is for 2.4.4.

pfSense2.sptest.net.local(config-ospf6)# area 0.0.4.175 nssa
% Unknown command: area 0.0.4.175 nssa
pfSense2.sptest.net.local(config-ospf6)# area 0.0.4.175
export-list Set the filter for networks announced to other areas
filter-list Filter networks between OSPF6 areas
import-list Set the filter for networks from other areas announced to the specified one
range Configured address range
stub Configure OSPF6 area as stub
pfSense2.sptest.net.local(config-ospf6)# area 0.0.4.175

Side note:
Our most common use case for using a product like pfSense is as a North-South Firewall. In that case nssa is the typical area type.
Because we are talking about OSPFv3/IPv6, a normal area would be an option as well (the amount of IPv6 routes in our environment is a lot smaller than the number of IPv4 routes)

#2 Updated by Marc Planquart about 1 year ago

Update:
It doesn't seem like FRR supports the NSSA area type. In fact, according to the documentation, it looks like it only really supports the Normal area type.
As a result, I would update the UI and "cleanup" Disable FIB updates. In addition, I'd suggest to rename this field to "Area type" with Normal (default) being the only option at this time (unless stub has been proven to be a valid option with the latest FRR release).

#3 Updated by Jim Pingle 4 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

I removed all but the normal and stub types in FRR pkg version 0.5.0, the underlying FRR was also upgraded so I left stub in so it can be used for testing for now.

#4 Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF