Project

General

Profile

Bug #8770

QinQ interfaces always show as active

Added by Steve Wheeler almost 2 years ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
08/08/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:
All

Description

In current 2.4.4 snapshots QinQ interface always appear to be UP and show carrier even when the parent interface (and VLAN interface) are down.

ix0: flags=28943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST,PPROMISC> metric 0 mtu 1500
    options=e507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:90:0b:76:8e:53
    hwaddr 00:90:0b:76:8e:53
    inet6 fe80::290:bff:fe76:8e53%ix0 prefixlen 64 scopeid 0x3
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: no carrier

ix0.100: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=600703<RXCSUM,TXCSUM,TSO4,TSO6,LRO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:90:0b:76:8e:53
    inet6 fe80::290:bff:fe76:8e53%ix0.100 prefixlen 64 scopeid 0xd
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect
    status: no carrier
    vlan: 100 vlanpcp: 0 parent interface: ix0
    groups: vlan

ix0.100.55: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
    options=28<VLAN_MTU,JUMBO_MTU>
    ether 00:90:0b:76:8e:53
    inet6 fe80::290:bff:fe76:8e53%ix0.100.55 prefixlen 64 scopeid 0xe
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active

This does not affect their functionality other then detecting failure if neither parent interface or VLAN are assigned.

History

#1 Updated by Viktor Gurov 4 months ago

This is FreeBSD issue
same on 12.1 for VLAN and QinQ interfaces

Also available in: Atom PDF