Project

General

Profile

Bug #8771

OpenVPN "custom options" box in GUI loses CR/LF (linefeeds) on save/reload meaning that OpenVPN then fails to start

Added by Andrew - almost 2 years ago. Updated almost 2 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/08/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

Apologies if I've missed it, but I couldn't see this issue has already been reported.

If you enter multiple custom options in OpenVPN you need to add linefeeds (i.e. press enter) to put each option on an individual line.

When you save the config in the GUI for OpenVPN it saves those. It works ok initially, but if you open up the OpenVPN config again you'll see that the linefeeds have all been removed - i.e. all the options are on one line. If you then re-save the config without putting the linefeeds back in, OpenVPN won't then start because the config is corrupted.

So the issue is that the pfSense isn't faithfully storing/reloading the custom options in the OpenVPN screen.

Thanks.

History

#1 Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Not a Bug

The CR/LF inconsistency is why the custom options must be separated by a semicolon (;) and not a CR/LF. This is stated in the help text immediately below the custom options box.

#2 Updated by Andrew - almost 2 years ago

Ok thanks - though semicolon in OpenVPN conf files designates a comment. Anyone cutting and pasting options and comments from an existing OpenVPN file might be tripped up by this as it seems pfSense will convert them into newlines without a semicolon.

Also available in: Atom PDF