Project

General

Profile

Actions

Feature #8777

closed

DHCPD - WebGUI Permit Classes and Matches If

Added by Abraham Fernandez about 3 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv4)
Target version:
-
Start date:
08/11/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:

Description

Permit from pfsense dhcp server gui to assign pools with classes and match if statements. For example for vendor-class-identifier option

class "imagenio" {
match if (substring (option vendor-class-identifier,0,5) = "[IAL]");
}

class "other" {
match if not (substring (option vendor-class-identifier,0,5) = "[IAL]");
}

subnet 10.10.0.0 netmask 255.255.255.0 {
    pool {
        allow members of "other";
        option domain-name-servers 10.10.0.1;
        range 10.10.0.2 10.10.0.150;
    }

    pool {
        allow members of "imagenio";
        option domain-name-servers 172.XXX.YYY.ZZZ;
        option custom-opt1-0-0 ":::::239.0.2.30:22222";
        range 10.10.0.200 10.10.0.207;
    }

    option routers 10.10.0.1;
    option domain-name-servers 10.10.0.1;
    option ntp-servers 10.10.0.1;

}

host s_opt1_0 {
        hardware ethernet XX:XX:XX:XX:XX:XX;
    fixed-address 10.10.0.240;
}
Actions #1

Updated by Jim Pingle about 2 years ago

  • Category set to DHCP (IPv4)
Actions #2

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Duplicate

Duplicate of #2983

Actions

Also available in: Atom PDF