Project

General

Profile

Bug #8803

PHP errors thrown in traffic shaper wizard multi

Added by Matthew Deets over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
08/18/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

When attempting to save changes in order to proceed to the next step in the wizard following prioritizing VoIP, the following error(s) are thrown if any options in the step are enabled.

PHP ERROR: Type: 1, File: /usr/local/www/wizard.php(180) : eval()'d code, Line: 1, Message: Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/wizard.php(180) : eval()'d code:1
Stack trace:
#0 /usr/local/www/wizard.php(180): eval()
#1 /usr/local/www/wizard.php(108): update_config_field('ezshaper->step5...', 'on', '', '', 'checkbox')
#2 {main}
thrown @ 2018-08-18 08:37:40

Associated revisions

Revision a34bab9f (diff)
Added by Steve Beaver over 1 year ago

Fixed #8803
Don't attempt to access $config elements that don't exist. PHP7 doesn't like it

History

#1 Updated by Matthew Deets over 1 year ago

Tested both the multi network and dedicated traffic shaper wizards and it appears that this issue is still occurring as of snapshot: 2.4.4.a.20180818.2240.

#2 Updated by Jim Pingle over 1 year ago

  • Project changed from pfSense Packages to pfSense
  • Category set to Traffic Shaper (ALTQ)
  • Target version set to 2.4.4
  • Affected Architecture All added
  • Affected Architecture deleted ()

#3 Updated by Steve Beaver over 1 year ago

  • Status changed from New to This Sprint

#4 Updated by Steve Beaver over 1 year ago

  • Assignee set to Steve Beaver

#5 Updated by Steve Beaver over 1 year ago

  • Status changed from This Sprint to Feedback

I am unable to reproduce this.

New VM running "out of the box" pfSense 2.4.4 snapshot from today

Number of wan conenctions: 1 => Next
Step 1 of 8 => accept defaults => Next
Step 2 of 8 Enable "Prioitize VOIP, set provider = generic, Upload and download rates set to 12 Mbps => Next
No errors observed.

#6 Updated by Matthew Deets over 1 year ago

Steve, Were you able to get through the entire shaper wizard with no errors when selecting to prioritize other protocols after the voip step? On my system, running the latest snapshot with an SG-2440 , I get this error after the prioritze voip step - wizard allows me to prioritize voip traffic with no issues; if I select the checkbox to enable any higher or lower prioritized protocols in any of the later steps such as p2p or other protocols, it throws the PHP errors that I mentioned. I am able to get through the shaper wizard if I leave all of the steps after prioritize voip unchecked.

#7 Updated by Matthew Deets over 1 year ago

Just to be clear, the error(s) that I encountered which I thought perhaps could be a bug, occurred if any checkbox is enabled in any step after the prioritize VoIP step. If I leave I’ll check boxes and checked, the wizard completes successfully with no errors

#8 Updated by Steve Beaver over 1 year ago

  • Status changed from Feedback to This Sprint

Thanks for the extra detail. I was able to reproduce this after your clarification.

#9 Updated by Matthew Deets over 1 year ago

Sorry, forgot to mention the step… If I check enable for step 3 The “penalty box” and press “next“, that’s where the error first occurs.

#10 Updated by Steve Beaver over 1 year ago

The offending command is: $thisvar = &$config['ezshaper']['step4']['enable'];

#11 Updated by Steve Beaver over 1 year ago

  • Status changed from This Sprint to Feedback
  • % Done changed from 0 to 100

#12 Updated by Steve Beaver over 1 year ago

  • % Done changed from 100 to 50

Please confirm that this change eliminates the PHP error messages. The Wizard should now test to see if a required $config element is present, and if not, create it..

#13 Updated by Steve Beaver over 1 year ago

  • % Done changed from 50 to 100

#14 Updated by Matthew Deets over 1 year ago

Verified with the latest snapshot that all steps are able to be completed in the traffic shaper wizard with no PHP errors. however, the traffic shaper wizard does not seem to be functioning - qothershigh, qotherslow, gaming, p2p, etc queues and floating rules were not created after the finish button was selected.

#15 Updated by Steve Beaver over 1 year ago

I have retested and don't see any problems. Since I pushed the update in two commits an hour apart, it is possible you caught it in between zapping the errors and fixing the config save. Please retest with snapshot from today. I have asked our QC team to do the same.

#16 Updated by Matthew Deets over 1 year ago

Updated to the latest snap shot this morning and retested. The traffic shaper wizard now works as expected with no errors. :)

#17 Updated by Steve Beaver over 1 year ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF