Project

General

Profile

Actions

Bug #8847

closed

IPsec status "Show Child SA entries" button only expands and never collapses

Added by Marcio Gomes over 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Very Low
Assignee:
Category:
IPsec
Target version:
Start date:
08/28/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

I am using version 2.4.4, I noticed that in ipsec status when clicking (+) Show child SA entries is shown the details ..
Only when clicking back nothing happens.

I also noticed that there is duplicate information .. and in Reuath in the tunnel IPSEC A is not shown

seconds (-)


Files

ipsec_status.png (77.3 KB) ipsec_status.png Marcio Gomes, 08/28/2018 05:45 PM
Actions #1

Updated by Steve Beaver over 3 years ago

  • Target version changed from 2.4.4 to Future
Actions #2

Updated by Jim Pingle over 2 years ago

  • Subject changed from IPsec status to IPsec status "Show Child SA entries" button only expands and never collapses
  • Category set to IPsec
  • Priority changed from Normal to Very Low

The "Show Child SA entries" button only expands and never collapses. That is surely something we can fix eventually, though it's just cosmetic, refresh the page and it's collapsed again.

The duplicate info is normal, we show what strongSwan shows. If it's in the GUI, it's what's in strongSwan, so that's what it has. Might be a rekey or it may have been negotiated in both directions, for example.

Actions #3

Updated by Jim Pingle almost 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Jim Pingle
  • Target version changed from Future to 2.5.0
  • Affected Version set to All
  • Affected Architecture All added
  • Affected Architecture deleted (amd64)

I've fixed this as a part of a larger set of changes about to be committed.

Actions #4

Updated by Jim Pingle almost 2 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.5.0 to 2.4.5

I backported the status_ipsec.php changes that fixed this to 2.4.5 as well, see 7ba6c13bc6

Actions #6

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

When clicked, the button disappears and the child list is expanded, which is the intended behavior.
2.4.5.a.20191217.0637

Actions

Also available in: Atom PDF