Project

General

Profile

Bug #8850

Packages that start on sync are started multiple times at boot

Added by Jim Pingle 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Package System
Target version:
Start date:
08/29/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

When /etc/rc.start_packages is run, for example at boot time, it performs a package sync with sync_package() and then its service is started with start_service(). The problem is that packages may already start the service on their own during their sync_package() call, thus leading to multiple starts unintentionally.

Related to #8620

Associated revisions

Revision 5d4f4900 (diff)
Added by Jim Pingle 12 months ago

Allow packages to opt out of a forced start. Fixes #8850

If a package performs its own service start during its sync process,
then add <starts_on_sync/> to its service definition in the package XML
file. Then when rc.start_packages is called, the forced start will not
happen since the sync will have taken that action already.

Revision 880107d2 (diff)
Added by Jim Pingle 12 months ago

Missing line to fix #8850

History

#1 Updated by Jim Pingle 12 months ago

  • Status changed from New to In Progress

#2 Updated by Jim Pingle 12 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle 12 months ago

  • % Done changed from 100 to 0

#4 Updated by Steve Beaver 12 months ago

  • Status changed from Feedback to Resolved

Tested with arpwatch installing fresh, configuring and multiple reboots

#5 Updated by Jim Pingle 12 months ago

  • Status changed from Resolved to This Sprint

Looks like one line of the fix didn't make it into the final commit. Will push a correction momentarily after re-testing.

#6 Updated by Jim Pingle 12 months ago

  • Status changed from This Sprint to Feedback
  • % Done changed from 0 to 100

#7 Updated by Jim Pingle 12 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF