Project

General

Profile

Bug #8876

status_gateway_groups.php: PHP error when there is no gateways array

Added by Jim Pingle over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Gateways
Target version:
Start date:
09/05/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

[05-Sep-2018 04:52:59 Etc/UTC] PHP Warning: Illegal string offset 'gateway_group' in /usr/local/www/status_gateway_groups.php on line 39
[05-Sep-2018 04:52:59 Etc/UTC] PHP Warning: Illegal string offset 'gateway_group' in /usr/local/www/status_gateway_groups.php on line 42
[05-Sep-2018 04:52:59 Etc/UTC] PHP Fatal error: Uncaught Error: Cannot create references to/from string offsets in /usr/local/www/status_gateway_groups.php:42

Associated revisions

Revision b54a1af4 (diff)
Added by Jim Pingle over 1 year ago

Init gateway group array before use. Fixes #8876

Revision 7d80bbbe (diff)
Added by Jim Pingle over 1 year ago

Init gateway group array before use. Fixes #8876

(cherry picked from commit b54a1af45c5add4e57253bfa0b562dadf3ae10f7)

History

#1 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback

Fix committed, will be in snaps when they are running again.

#2 Updated by Jim Pingle over 1 year ago

  • % Done changed from 0 to 100

#3 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Can't reproduce any errors on gateway status in the latest RC build, even without <gateway></gateway> tags in the config

Also available in: Atom PDF