Project

General

Profile

Bug #8891

PHP error with an empty CRL

Added by Jim Pingle over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Certificates
Target version:
Start date:
09/12/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

If a CRL contains no certificates, a PHP error appears in the contents of the page

PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/www/system_crlmanager.php on line 641

To reproduce, create a new CRL and the error will appear in the CRL list because a new CRL does not yet contain any certificates.

Fixed in d9064f0b92452daeaf0cb7f0a0e74561f246ed5b (master) and 3d9d84d4bb3972bfddc30b1b35152ae3ba7c1cb8 (RELENG_2_4_4)

History

#1 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Fixed on latest RC snap.

Also available in: Atom PDF