Project

General

Profile

Bug #8916

Package Shellcmd doesn't install

Added by BBcan177 . almost 2 years ago. Updated almost 2 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/18/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

2.4.4-DEVELOPMENT (amd64)
built on Tue Sep 04 10:04:12 EDT 2018
FreeBSD 11.2-RELEASE-p2

PHP ERROR: Type: 1, File: /usr/local/pkg/shellcmd.inc, Line: 115,
Message: Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/shellcmd.inc:115

Dashboard Notice:

PHP Errors:
[18-Sep-2018 22:19:29 America/Toronto] PHP Fatal error:  Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/shellcmd.inc:115
Stack trace:
#0 /etc/inc/pkg-utils.inc(768) : eval()'d code(1): shellcmd_sync_package()
#1 /etc/inc/pkg-utils.inc(768): eval()
#2 /etc/inc/pkg-utils.inc(859): eval_once('shellcmd_sync_p...')
#3 /etc/rc.packages(74): install_package_xml('Shellcmd')
#4 {main}
  thrown in /usr/local/pkg/shellcmd.inc on line 115
[18-Sep-2018 22:19:34 America/Toronto] PHP Warning:  Illegal string offset 'config' in /usr/local/pkg/shellcmd.inc on line 115
[18-Sep-2018 22:19:34 America/Toronto] PHP Fatal error:  Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/shellcmd.inc:115
Stack trace:
#0 /etc/inc/pkg-utils.inc(705) : eval()'d code(1): shellcmd_sync_package()
#1 /etc/inc/pkg-utils.inc(705): eval()
#2 /etc/rc.start_packages(58): sync_package('Shellcmd')
#3 {main}
  thrown in /usr/local/pkg/shellcmd.inc on line 115

Installer log:

>>> Installing pfSense-pkg-Shellcmd... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    pfSense-pkg-Shellcmd: 1.0.3 [pfSense]

Number of packages to be installed: 1

8 KiB to be downloaded.
[1/1] Fetching pfSense-pkg-Shellcmd-1.0.3.txz: . done
Checking integrity... done (0 conflicting)
[1/1] Installing pfSense-pkg-Shellcmd-1.0.3...
[1/1] Extracting pfSense-pkg-Shellcmd-1.0.3: ........ done
Saving updated package information...
done.
Loading package configuration... done.
Configuring package components...
Loading package instructions...
Custom commands...
Executing custom_php_install_command()...done.
Executing custom_php_resync_config_command()...
Fatal error: Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/shellcmd.inc:115
Stack trace:
#0 /etc/inc/pkg-utils.inc(768) : eval()'d code(1): shellcmd_sync_package()
#1 /etc/inc/pkg-utils.inc(768): eval()
#2 /etc/inc/pkg-utils.inc(859): eval_once('shellcmd_sync_p...')
#3 /etc/rc.packages(74): install_package_xml('Shellcmd')
#4 {main}
  thrown in /usr/local/pkg/shellcmd.inc on line 115
PHP ERROR: Type: 1, File: /usr/local/pkg/shellcmd.inc, Line: 115, Message: Uncaught Error: Cannot create references to/from string offsets in /usr/local/pkg/shellcmd.inc:115
Stack trace:
#0 /etc/inc/pkg-utils.inc(768) : eval()'d code(1): shellcmd_sync_package()
#1 /etc/inc/pkg-utils.inc(768): eval()
#2 /etc/inc/pkg-utils.inc(859): eval_once('shellcmd_sync_p...')
#3 /etc/rc.packages(74): install_package_xml('Shellcmd')
#4 {main}
  thrownpkg-static: POST-INSTALL script failed
>>> Cleaning up cache... done.
Success

History

#1 Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Not a Bug

2.4.4-DEVELOPMENT (amd64)
built on Tue Sep 04 10:04:12 EDT 2018
FreeBSD 11.2-RELEASE-p2

That snapshot is very old. Update to the RC and try again. That has been fixed a while ago.

I just installed shellcmd on the latest RC, on a box that never had shellcmd, and it installed without error.

Also available in: Atom PDF