Project

General

Profile

Bug #8944

attemp of installing pfblocker brakes system on 2.4.3

Added by Constantine Kormashev 9 months ago. Updated 9 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
-
Start date:
09/25/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3_1
Affected Architecture:

Description

Any attempt to install pfblocker on clean 2.4.3-p1 breaks system.
Errors during installation:

Sep 25 08:20:30 pfSense php-fpm[329]: /pkg_mgr_install.php: PHP ERROR: Type: 64, File: /etc/inc/radius.inc, Line: 50, Message: require_once(): Failed opening required '/usr/local/share/pear/PEAR.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear')
Sep 25 08:20:30 pfSense php-fpm[329]: /pkg_mgr_install.php: New alert found: PHP ERROR: Type: 64, File: /etc/inc/radius.inc, Line: 50, Message: require_once(): Failed opening required '/usr/local/share/pear/PEAR.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear')

System generates many php warnings related to some shared objects.

...many similar messages...

"/usr/local/lib/php/20131226/zmq.so.so")) in Unknown on line 0
[25-Sep-2018 08:42:50 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'pdo_sqlite.so' (tried: /usr/local/lib/php/20131226/pdo_sqlite.so (Cannot open "/usr/local/lib/php/20131226/pdo_sqlite.so"), /usr/local/lib/php/20131226/pdo_sqlite.so.so (Cannot open "/usr/local/lib/php/20131226/pdo_sqlite.so.so")) in Unknown on line 0
[25-Sep-2018 08:42:50 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'xmlreader.so' (tried: /usr/local/lib/php/20131226/xmlreader.so (Cannot open "/usr/local/lib/php/20131226/xmlreader.so"), /usr/local/lib/php/20131226/xmlreader.so.so (Cannot open "/usr/local/lib/php/20131226/xmlreader.so.so")) in Unknown on line 0
[25-Sep-2018 08:42:50 Etc/UTC] PHP Fatal error:  Uncaught Error: Call to undefined function gettext() in /etc/inc/certs.inc:44
Stack trace:
#0 /etc/inc/functions.inc(32): require_once()
#1 /etc/inc/notices.inc(24): require_once('/etc/inc/functi...')
#2 /etc/inc/config.inc(49): require_once('/etc/inc/notice...')
#3 /etc/rc.packages(28): require_once('/etc/inc/config...')
#4 {main}
  thrown in /etc/inc/certs.inc on line 44

Problem is system does not complete boot process: interfaces do not have addresses, pf is not stated, any attempts of execute php lead to errors:

PHP ERROR: Type: 64, File: /etc/inc/config.inc, Line: 51, Message: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form:/usr/local/share/pear')

I am not sure, but have small suspicious php errors like this might affect update to 2.4.4. Because we have got some tickets with the same error messages (e.g. #12741).

The issue affects only 2.4.3-p1. Versions 2.4.4 and 2.3.4-p1 are able to install pfblocker without trouble.

PHP_errors.log (131 KB) PHP_errors.log Constantine Kormashev, 09/25/2018 04:11 AM
err.png (189 KB) err.png Constantine Kormashev, 09/25/2018 04:11 AM

History

#1 Updated by Jim Pingle 9 months ago

  • Status changed from New to Duplicate

Duplicate of #8938

Also available in: Atom PDF