Project

General

Profile

Bug #8957

Prefix ID for IPv6 tracked interfaces cannot be set

Added by Jason McCormick 8 months ago. Updated 8 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
09/26/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:

Description

After a painful, ultimately unsuccessful in-place upgrade to 2.4.4 from 2.4.3-p1, I needed to rebuild my config by hand (the box was unstable, igb0 (WAN) was physically linking and unlinking every 2 seconds). I think I found at least one of the issues. If you have an interface using IPv6 by tracking another interface, the Prefix ID cannot be altered to get different subnets. There seems to be a validation bug in the field code. It says the valid hex values are "0 to 0". This is not just a label issue as you cannot save the prefix value either. This was working find in 2.4.3-p1.

pf_ipv6_1.png (21.5 KB) pf_ipv6_1.png Jason McCormick, 09/26/2018 06:43 AM
pf_ipv6_2.png (13.5 KB) pf_ipv6_2.png Jason McCormick, 09/26/2018 06:43 AM

History

#1 Updated by Jim Pingle 8 months ago

  • Status changed from New to Not a Bug
  • Priority changed from High to Normal

That means you did not set the WAN DHCPv6 Prefix Delegation size properly, it may be at the default of /64 when it should be set to match what the ISP sends you.

#2 Updated by Jason McCormick 8 months ago

Ahh.. Sorry for the false bug. Trying to set this all up and I missed it.

Also available in: Atom PDF