Project

General

Profile

Bug #9028

Acme pkg upgrade caused pfSense to try upgrade 2.4.3 -> 2.4.4, failed

Added by Eduard Rozenberg 8 months ago. Updated 8 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/09/2018
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.3_1
Affected Architecture:

Description

I clicked on the update button next to the Acme package on the dashboard. This appears to have caused pfSense to try to upgrade many packages including php and the base pfSense package (pfSense-2.4.3.txz). It stopped during this process at:

[6/113] Deleting files for pear-Cache_Lite-1.7.16,1.....
and nothing further happened.

Currently the system is still running and routing traffic (yay!), but it is in a somewhat broken state with a few updated php packages and no ability to upgrade cleanly to 2.4.4.

Things I thought to try:
  • Upgrade the system to 2.4.4. But I'm not able to click the upgrade button now because the system shows "The system is on a later version than official release.", "Latest Base System - Warning:", "Status - Running a newer version."
  • Download the 2.4.3 release and look for packages on the ISO, so I can restore the previous packages to the system. I couldn't find any packages on the ISO (pfSense-CE-2.4.3-RELEASE-amd64.iso.gz), only individual files in various directories. Also - was hard to even find the 2.4.3 release, only on a couple of outdated sites such as http://linorg.usp.br/pfsense/downloads/ which I don't even know I can trust. The official download site does not provide any older versions.

I can't figure out where I could download individual packages that were updated such as pfSense-2.4.3.txz and pear-Net_URL2-2.2.1.

Thanks in advance for any hints. At this point I only would know how to reinstall the whole system from scratch despite only needing a few older packages to get back to the previous state.

>>> Upgrading pfSense-pkg-acme... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pfSense repository is up to date.
All repositories are up to date.
The following 6 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
    php72-pecl-ssh2: 1.1.2 [pfSense]
    php72: 7.2.10 [pfSense]
    libargon2: 20171227 [pfSense]
    php72-ftp: 7.2.10 [pfSense]

Installed packages to be UPGRADED:
    pfSense-pkg-acme: 0.3.2 -> 0.3.2_4 [pfSense]
    socat: 1.7.3.2_2 -> 1.7.3.2_3 [pfSense]

Number of packages to be installed: 4
Number of packages to be upgraded: 2

The process will require 25 MiB more space.
4 MiB to be downloaded.
[1/6] Fetching pfSense-pkg-acme-0.3.2_4.txz: .......... done
[2/6] Fetching php72-pecl-ssh2-1.1.2.txz: .... done
[3/6] Fetching php72-7.2.10.txz: .......... done
[4/6] Fetching libargon2-20171227.txz: ........ done
[5/6] Fetching socat-1.7.3.2_3.txz: .......... done
[6/6] Fetching php72-ftp-7.2.10.txz: ... done
Checking integrity... done (3 conflicting)
  - php72-pecl-ssh2-1.1.2 [pfSense] conflicts with pecl-ssh2-0-0.13 [installed] on /usr/local/include/php/ext/ssh2/php_ssh2.h
  - php72-7.2.10 [pfSense] conflicts with php56-5.6.34 [installed] on /usr/local/bin/php
  - php72-ftp-7.2.10 [pfSense] conflicts with php56-ftp-5.6.34 [installed] on /usr/local/include/php/ext/ftp/config.h
Checking integrity... done (0 conflicting)
Conflicts with the existing packages have been found.
One more solver iteration is needed to resolve them.
The following 113 package(s) will be affected (of 0 checked):

Installed packages to be REMOVED:
    pear-XML_RPC2-1.1.3
    pear-Mail-1.4.1,1
    pear-HTTP_Request2-2.3.0,1
    pear-Net_SMTP-1.8.0
    pear-Net_URL2-2.2.1
    pear-Cache_Lite-1.7.16,1
    pear-Crypt_CHAP-1.5.0
    pear-Net_Socket-1.0.14
    pear-Net_IPv6-1.3.0.b2_2
    pear-Net_Growl-2.7.0
    pear-Auth_RADIUS-1.1.0
    php56-xmlreader-5.6.34
    pear-1.10.5_1
    php-suhosin-0.9.38_3
    php56-xmlwriter-5.6.34
    php56-dom-5.6.34
    php56-xml-5.6.34
    php56-pdo_sqlite-5.6.34
    php56-simplexml-5.6.34
    php56-session-5.6.34
    php56-opcache-5.6.34
    php56-zlib-5.6.34
    php56-curl-5.6.34
    pecl-zmq-1.1.3_2
    php56-sqlite3-5.6.34
    php56-pdo-5.6.34
    php56-mcrypt-5.6.34
    php56-hash-5.6.34
    php56-pfSense-module-0.61
    pecl-radius-1.4.0.b1
    php56-ctype-5.6.34
    php56-posix-5.6.34
    php56-openssl-5.6.34
    php56-filter-5.6.34
    php56-sockets-5.6.34
    php56-ldap-5.6.34
    php56-bcmath-5.6.34
    php56-tokenizer-5.6.34
    php56-sysvshm-5.6.34
    php56-sysvsem-5.6.34
    php56-sysvmsg-5.6.34
    php56-shmop-5.6.34
    php56-readline-5.6.34
    php56-pcntl-5.6.34
    php56-json-5.6.34
    php56-gettext-5.6.34
    php56-mbstring-5.6.34
    php56-bz2-5.6.34
    php56-5.6.34
    pecl-ssh2-0-0.13
    pecl-rrd1-1.1.3
    php56-ftp-5.6.34

New packages to be INSTALLED:
    libargon2: 20171227 [pfSense]
    php72: 7.2.10 [pfSense]
    php72-xml: 7.2.10 [pfSense]
    php72-zlib: 7.2.10 [pfSense]
    php72-pear: 1.10.5_1 [pfSense]
    oniguruma: 6.8.1 [pfSense]
    php72-pear-Net_URL2: 2.2.1 [pfSense]
    php72-pear-Net_Socket: 1.0.14 [pfSense]
    php72-pecl-rrd: 2.0.1_1 [pfSense]
    php72-curl: 7.2.10 [pfSense]
    php72-tokenizer: 7.2.10 [pfSense]
    php72-mbstring: 7.2.10 [pfSense]
    php72-dom: 7.2.10 [pfSense]
    php72-openssl: 7.2.10 [pfSense]
    php72-hash: 7.2.10 [pfSense]
    php72-bcmath: 7.2.10 [pfSense]
    php72-pecl-mcrypt: 1.0.1 [pfSense]
    php72-pecl-radius: 1.4.0.b1 [pfSense]
    php72-pear-HTTP_Request2: 2.3.0,1 [pfSense]
    php72-pear-Cache_Lite: 1.7.16,1 [pfSense]
    php72-pear-Net_SMTP: 1.8.0 [pfSense]
    php72-pdo: 7.2.10 [pfSense]
    php72-pecl-ssh2: 1.1.2 [pfSense]
    php72-simplepie: 1.5.1_1 [pfSense]
    php72-session: 7.2.10 [pfSense]
    php72-opcache: 7.2.10 [pfSense]
    php72-xmlwriter: 7.2.10 [pfSense]
    php72-xmlreader: 7.2.10 [pfSense]
    php72-simplexml: 7.2.10 [pfSense]
    php72-ctype: 7.2.10 [pfSense]
    php72-posix: 7.2.10 [pfSense]
    sshguard: 2.2.0_4 [pfSense]
    php72-filter: 7.2.10 [pfSense]
    php72-openssl_x509_crl: 1.2 [pfSense]
    php72-pear-Crypt_CHAP: 1.5.0 [pfSense]
    openvpn-auth-script: 1.0.0.3 [pfSense]
    php72-sockets: 7.2.10 [pfSense]
    php72-ldap: 7.2.10 [pfSense]
    php72-pecl-zmq: 1.1.3_2 [pfSense]
    php72-pear-XML_RPC2: 1.1.3_1 [pfSense]
    php72-pear-Net_IPv6: 1.3.0.b2_2 [pfSense]
    php72-pear-Net_Growl: 2.7.0 [pfSense]
    php72-pear-Auth_RADIUS: 1.1.0_4 [pfSense]
    php72-pear-Mail: 1.4.1,1 [pfSense]
    php72-sysvshm: 7.2.10 [pfSense]
    php72-sysvsem: 7.2.10 [pfSense]
    php72-sysvmsg: 7.2.10 [pfSense]
    php72-shmop: 7.2.10 [pfSense]
    php72-readline: 7.2.10 [pfSense]
    php72-pcntl: 7.2.10 [pfSense]
    php72-json: 7.2.10 [pfSense]
    php72-gettext: 7.2.10 [pfSense]
    php72-pfSense-module: 0.64_6 [pfSense]
    php72-sqlite3: 7.2.10 [pfSense]
    php72-pdo_sqlite: 7.2.10 [pfSense]
    php72-bz2: 7.2.10 [pfSense]
    php72-ftp: 7.2.10 [pfSense]

Installed packages to be UPGRADED:
    socat: 1.7.3.2_2 -> 1.7.3.2_3 [pfSense]
    pfSense-pkg-acme: 0.3.2 -> 0.3.2_4 [pfSense]
    pfSense: 2.4.3_1 -> 2.4.4 [pfSense]

Installed packages to be REINSTALLED:
    pfSense-Status_Monitoring-1.7.6 [pfSense] (direct dependency changed: php72)

Number of packages to be removed: 52
Number of packages to be installed: 57
Number of packages to be upgraded: 3
Number of packages to be reinstalled: 1

The process will require 10 MiB more space.
3 MiB to be downloaded.
[1/55] Fetching php72-xml-7.2.10.txz: ... done
[2/55] Fetching php72-zlib-7.2.10.txz: ... done
[3/55] Fetching php72-pear-1.10.5_1.txz: .......... done
[4/55] Fetching oniguruma-6.8.1.txz: .......... done
[5/55] Fetching php72-pear-Net_URL2-2.2.1.txz: ... done
[6/55] Fetching php72-pear-Net_Socket-1.0.14.txz: . done
[7/55] Fetching php72-pecl-rrd-2.0.1_1.txz: .. done
[8/55] Fetching php72-curl-7.2.10.txz: .... done
[9/55] Fetching php72-tokenizer-7.2.10.txz: .. done
[10/55] Fetching php72-mbstring-7.2.10.txz: .......... done
[11/55] Fetching php72-dom-7.2.10.txz: ....... done
[12/55] Fetching php72-openssl-7.2.10.txz: ....... done
[13/55] Fetching php72-hash-7.2.10.txz: .......... done
[14/55] Fetching php72-bcmath-7.2.10.txz: ... done
[15/55] Fetching php72-pecl-mcrypt-1.0.1.txz: .. done
[16/55] Fetching php72-pecl-radius-1.4.0.b1.txz: ... done
[17/55] Fetching php72-pear-HTTP_Request2-2.3.0,1.txz: .......... done
[18/55] Fetching php72-pear-Cache_Lite-1.7.16,1.txz: .... done
[19/55] Fetching php72-pear-Net_SMTP-1.8.0.txz: .. done
[20/55] Fetching php72-pdo-7.2.10.txz: ...... done
[21/55] Fetching pfSense-Status_Monitoring-1.7.6.txz: ... done
[22/55] Fetching php72-simplepie-1.5.1_1.txz: ......... done
[23/55] Fetching php72-session-7.2.10.txz: ..... done
[24/55] Fetching php72-opcache-7.2.10.txz: .......... done
[25/55] Fetching php72-xmlwriter-7.2.10.txz: .. done
[26/55] Fetching php72-xmlreader-7.2.10.txz: .. done
[27/55] Fetching php72-simplexml-7.2.10.txz: ... done
[28/55] Fetching php72-ctype-7.2.10.txz: . done
[29/55] Fetching php72-posix-7.2.10.txz: .. done
[30/55] Fetching sshguard-2.2.0_4.txz: .......... done
[31/55] Fetching php72-filter-7.2.10.txz: ... done
[32/55] Fetching php72-openssl_x509_crl-1.2.txz: .. done
[33/55] Fetching php72-pear-Crypt_CHAP-1.5.0.txz: . done
[34/55] Fetching openvpn-auth-script-1.0.0.3.txz: . done
[35/55] Fetching php72-sockets-7.2.10.txz: ..... done
[36/55] Fetching php72-ldap-7.2.10.txz: ... done
[37/55] Fetching php72-pecl-zmq-1.1.3_2.txz: .... done
[38/55] Fetching php72-pear-XML_RPC2-1.1.3_1.txz: ........ done
[39/55] Fetching php72-pear-Net_IPv6-1.3.0.b2_2.txz: .. done
[40/55] Fetching php72-pear-Net_Growl-2.7.0.txz: .......... done
[41/55] Fetching php72-pear-Auth_RADIUS-1.1.0_4.txz: .. done
[42/55] Fetching php72-pear-Mail-1.4.1,1.txz: ... done
[43/55] Fetching php72-sysvshm-7.2.10.txz: . done
[44/55] Fetching php72-sysvsem-7.2.10.txz: . done
[45/55] Fetching php72-sysvmsg-7.2.10.txz: . done
[46/55] Fetching php72-shmop-7.2.10.txz: . done
[47/55] Fetching php72-readline-7.2.10.txz: .. done
[48/55] Fetching php72-pcntl-7.2.10.txz: .. done
[49/55] Fetching php72-json-7.2.10.txz: ... done
[50/55] Fetching php72-gettext-7.2.10.txz: . done
[51/55] Fetching php72-pfSense-module-0.64_6.txz: ...... done
[52/55] Fetching php72-sqlite3-7.2.10.txz: ... done
[53/55] Fetching php72-pdo_sqlite-7.2.10.txz: .. done
[54/55] Fetching php72-bz2-7.2.10.txz: .. done
[55/55] Fetching pfSense-2.4.4.txz: . done
[1/113] Deinstalling pear-XML_RPC2-1.1.3...
uninstall ok: channel://pear.php.net/XML_RPC2-1.1.3
[1/113] Deleting files for pear-XML_RPC2-1.1.3: 
pear-XML_RPC2-1.1.3: missing file /usr/local/share/doc/pear/XML_RPC2/docs/Makefile
[1/113] Deleting files for pear-XML_RPC2-1.1.3...
pear-XML_RPC2-1.1.3: missing file /usr/local/share/doc/pear/XML_RPC2/docs/tutorials/XML_RPC2.lyx
[1/113] Deleting files for pear-XML_RPC2-1.1.3............. done
[2/113] Deinstalling pear-Mail-1.4.1,1...
uninstall ok: channel://pear.php.net/Mail-1.4.1
[2/113] Deleting files for pear-Mail-1.4.1,1: 
pear-Mail-1.4.1,1: missing file /usr/local/share/doc/pear/Mail/LICENSE
[2/113] Deleting files for pear-Mail-1.4.1,1............. done
[3/113] Deinstalling pear-HTTP_Request2-2.3.0,1...
uninstall ok: channel://pear.php.net/HTTP_Request2-2.3.0
[3/113] Deleting files for pear-HTTP_Request2-2.3.0,1: 
pear-HTTP_Request2-2.3.0,1: missing file /usr/local/share/doc/pear/HTTP_Request2/LICENSE
[3/113] Deleting files for pear-HTTP_Request2-2.3.0,1...
pear-HTTP_Request2-2.3.0,1: missing file /usr/local/share/doc/pear/HTTP_Request2/examples/upload-rapidshare.php
[3/113] Deleting files for pear-HTTP_Request2-2.3.0,1............. done
[4/113] Deinstalling pear-Net_SMTP-1.8.0...
uninstall ok: channel://pear.php.net/Net_SMTP-1.8.0
[4/113] Deleting files for pear-Net_SMTP-1.8.0: 
pear-Net_SMTP-1.8.0: missing file /usr/local/share/doc/pear/Net_SMTP/LICENSE
[4/113] Deleting files for pear-Net_SMTP-1.8.0...
pear-Net_SMTP-1.8.0: missing file /usr/local/share/doc/pear/Net_SMTP/docs/guide.txt
[4/113] Deleting files for pear-Net_SMTP-1.8.0...
pear-Net_SMTP-1.8.0: missing file /usr/local/share/doc/pear/Net_SMTP/examples/basic.php
[4/113] Deleting files for pear-Net_SMTP-1.8.0........... done
[5/113] Deinstalling pear-Net_URL2-2.2.1...
uninstall ok: channel://pear.php.net/Net_URL2-2.2.1
[5/113] Deleting files for pear-Net_URL2-2.2.1: 
pear-Net_URL2-2.2.1: missing file /usr/local/share/doc/pear/Net_URL2/docs/6470.php
[5/113] Deleting files for pear-Net_URL2-2.2.1...
pear-Net_URL2-2.2.1: missing file /usr/local/share/doc/pear/Net_URL2/docs/BSD-3-CLAUSE-Heyes
[5/113] Deleting files for pear-Net_URL2-2.2.1...
pear-Net_URL2-2.2.1: missing file /usr/local/share/doc/pear/Net_URL2/docs/example.php
[5/113] Deleting files for pear-Net_URL2-2.2.1.......... done
[6/113] Deinstalling pear-Cache_Lite-1.7.16,1...
uninstall ok: channel://pear.php.net/Cache_Lite-1.7.16
[6/113] Deleting files for pear-Cache_Lite-1.7.16,1: 
pear-Cache_Lite-1.7.16,1: missing file /usr/local/share/doc/pear/Cache_Lite/LICENSE
[6/113] Deleting files for pear-Cache_Lite-1.7.16,1...
pear-Cache_Lite-1.7.16,1: missing file /usr/local/share/doc/pear/Cache_Lite/README.md
[6/113] Deleting files for pear-Cache_Lite-1.7.16,1...
pear-Cache_Lite-1.7.16,1: missing file /usr/local/share/doc/pear/Cache_Lite/TODO
[6/113] Deleting files for pear-Cache_Lite-1.7.16,1...
pear-Cache_Lite-1.7.16,1: missing file /usr/local/share/doc/pear/Cache_Lite/docs/examples
[6/113] Deleting files for pear-Cache_Lite-1.7.16,1...
pear-Cache_Lite-1.7.16,1: missing file /usr/local/share/doc/pear/Cache_Lite/docs/technical
[6/113] Deleting files for pear-Cache_Lite-1.7.16,1.....

History

#1 Updated by Jim Pingle 8 months ago

  • Status changed from New to Duplicate

Duplicate of #8938

Also available in: Atom PDF