Project

General

Profile

Actions

Bug #9150

closed

Web authentication RADIUS package shows PHP error if unable to resolve FQDN of RADIUS server

Added by Andrew Taylor about 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Authentication
Target version:
Start date:
11/25/2018
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.x
Affected Architecture:
All

Description

When the DNS record for the RADIUS server used to configure authentication of the web console was temporarily unavailable, any attempt to log into the web interface gave the following error message:

Fatal error: Error converting Address in /usr/local/share/pear/Auth/RADIUS.php on line 218 PHP ERROR: Type: 1, File: /usr/local/share/pear/Auth/RADIUS.php, Line: 218, Message: Error converting Address

This makes sense given that DNS lookup failure also means the RADIUS server won't be reachable, but I believe the system should fallback to locally configured users. Since it errors out before that point, it does not get a chance to fail to local.

Actions #1

Updated by Jim Pingle over 2 years ago

  • Assignee set to Jim Pingle
  • Target version set to 2.5.0
Actions #2

Updated by Jim Pingle over 2 years ago

I never could reproduce this with any combination of DNS failures (no server, server timeout, nxdomain, etc) but I added some exception handling that should catch it if it happens again.

Actions #3

Updated by Jim Pingle over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.5.0 to 2.4.5
Actions #5

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

I still was not able to reproduce this, even on 2.4.4-p3, but it all works as expected on 2.4.5. Auth appears to fail gracefully.

Actions

Also available in: Atom PDF