Project

General

Profile

Bug #944

Moving VLANs to lagg doesn't remove old VLANs

Added by Chris Buechler over 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
10/11/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When moving a VLAN from a physical interface to lagg (amongst other possible scenarios), you end up with duplicate VLANs configured - one on the previous physical interface and one on the lagg.

Associated revisions

Revision df2a0f18 (diff)
Added by Ermal Luçi over 8 years ago

Resolves #944. Actually bring down the vlan interface if it existed previously. This is a regression from the ppp dance/requests/whatever.

Revision 6b78bed7 (diff)
Added by Ermal Luçi over 8 years ago

Ticket #944. Wehn changing the parent interface make sure to destroy the old vlan before creating the new one. Since vlans use the name of the parent the old interface referencing the old parent vlan will remain intact.

Revision 0f70d563 (diff)
Added by Ermal Luçi over 8 years ago

Ticket #944. Do not use the interface_bring_down fucntion here since it is meant for assigned interfaces. Directly destroy previous vlan interface if parent changes.

Revision 695a35ae (diff)
Added by Ermal Luçi almost 8 years ago

Ticket #944. Also destory the previous interface if the user changing the vlan tag of an existing vlan entry.

Revision 6b421a0f (diff)
Added by Ermal Luçi almost 8 years ago

Fixes #944. Use the correct interface name to destroy the previous vlan if the parent is changed.

History

#1 Updated by Ermal Luçi over 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to New

Still leaves behind the old VLAN.

em1_vlan5: flags=8003<UP,BROADCAST,MULTICAST> metric 0 mtu 1500
        ether 00:00:00:00:00:00
        inet6 fe80::290:bff:fe12:166%em1_vlan5 prefixlen 64 scopeid 0xf
        nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
        vlan: 0 parent interface: <none>

#3 Updated by Ermal Luçi over 8 years ago

  • Status changed from New to Feedback

Committed the fix even on vlan config page.
Please test!

#4 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to New

no change. When changing a VLAN from a physical interface to lagg or vice versa, it leaves the old VLAN interface as well as adding the new.

#5 Updated by Ermal Luçi over 8 years ago

  • Status changed from New to Feedback

Committed the other fix because the previous relied on interface being assigned.

#6 Updated by Andreas Bochem about 8 years ago

Bug still exists in 2.0-RC1 (amd64) build on Mon May 9 04:17:17 EDT 2011.

Tested:
  1. create vlan 66 on em0 -> ifconfig shows em0_vlan66
  2. edit vlan 66 to be on lagg1 -> ifconfig shows both em0_vlan66 and lagg1_vlan66
  3. remove vlan 66 -> ifconfig shows lagg1_vlan66 removed, em0_vlan66 still present

#7 Updated by Andreas Bochem almost 8 years ago

still in 2.0-RC2 built on Tue May 31 12:13:03 EDT 2011

#8 Updated by Ermal Luçi almost 8 years ago

I just pushed some fixes.
Please gitsync and verify they work correctly now.

#9 Updated by Ermal Luçi almost 8 years ago

#10 Updated by Andreas Bochem almost 8 years ago

confirm fixed in 2.0-RC3 (amd64) built on Tue Jun 21 23:37:22 EDT 2011

#11 Updated by Chris Buechler almost 8 years ago

  • Status changed from Feedback to Resolved

thanks

Also available in: Atom PDF