Project

General

Profile

Bug #9477

2.4.4-RELEASE-p2 + XG-1537 SFP+ port issue - critical

Added by Kristian Junkov over 1 year ago. Updated over 1 year ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
04/15/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4_2
Affected Architecture:
amd64

Description

If something is installed in the SFP+ Ports on the XG-1537 then the interfaces ix0 and ix1 will not come up during boot or reboot.

Start system without any SFP+ installed. Install SFP+ into adapter. It is possible to get link on ix0 and ix1.
Reboot system and ix0 and ix1 is no longer available in the system. This also means that interface assignment is borked and therefore the firewall cannot come back after powerloss or planned reboot without physical presence. To bring back up you need to physically remove both SPF+ devices and then reboot - wait until boot is finished and then reinsert.

ix0 LAN connected with 10Gbit DAC cable - currently not connected in the other end.
ix1 WAN connected with 10Gbit LC optics connected to ISP

ifconfig -vvvvvv

ix0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e400bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
ether ac:1f:6b:xx:xx:xx
hwaddr ac:1f:6b:xx:xx:xx
inet6 xxxx::xxxx:xxxx:xxxx:3c%ix0 prefixlen 64 scopeid 0x1
inet6 xxxx::xxxx:xxxx:: prefixlen 50
inet 172.16.0.1 netmask 0xffff0000 broadcast 172.16.255.255
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect
status: no carrier
plugged: SFP/SFP+/SFP28 Unknown (Copper pigtail)
vendor: MOSAIC PN: C-FT39T1 SN: CIB180126468 DATE: 2018-01-26

SFF8472 DUMP (0xA0 0..127 range):
03 04 21 00 00 00 00 00 04 00 00 00 67 00 00 00
00 00 01 00 4D 4F 53 41 49 43 20 20 20 20 20 20
20 20 20 20 00 00 00 00 43 2D 46 54 33 39 54 31
20 20 20 20 20 20 20 20 20 20 20 20 03 52 00 60
00 00 00 00 43 49 42 31 38 30 31 32 36 34 36 38
20 20 20 20 31 38 30 31 32 36 20 20 00 00 00 94
80 00 11 74 57 98 2C 6D 06 A4 55 9D 26 93 96 24
13 7B B3 00 00 00 00 00 00 00 00 00 DF CE C2 97

ix1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e400bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
ether ac:1f:6b:xx:xx:xx
hwaddr ac:1f:6b:xx:xx:xx
inet6 xxxx::xxxx:xxxx:xxxx:3d%ix1 prefixlen 64 scopeid 0x2
inet6 xxxx::xxxx:xxxx:xxxx:62 prefixlen 125
inet xxx.xxx.xxx.xxx netmask 0xfffffff8 broadcast xxx.xxx.xxx.xxx
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
media: Ethernet autoselect (Unknown <rxpause,txpause>)
status: active
plugged: SFP/SFP+/SFP28 Unknown (LC)
vendor: OEM PN: C-FT3980D-51 SN: CIB160617209 DATE: 2016-06-28
module temperature: 50.89 C Voltage: 3.33 Volts
RX: 0.11 mW (-9.48 dBm) TX: 1.85 mW (2.68 dBm)

As you can see media is also not properly detected and set to (Unknown <rxpause,txpause>).

Shell Output - dmesg | grep ix

acpi0: Power Button (fixed)
ix0: <Intel(R) PRO/10GbE PCI-Express Network Driver, Version - 3.2.12-k> mem 0xfbc00000-0xfbdfffff,0xfbe04000-0xfbe07fff irq 11 at device 0.0 on pci4
ix0: Using MSI-X interrupts with 9 vectors
ix0: Ethernet address: ac:1f:6b:8d:00:3c
ix0: netmap queues/slots: TX 8/2048, RX 8/2048
ix1: <Intel(R) PRO/10GbE PCI-Express Network Driver, Version - 3.2.12-k> mem 0xfba00000-0xfbbfffff,0xfbe00000-0xfbe03fff irq 10 at device 0.1 on pci4
ix1: Using MSI-X interrupts with 9 vectors
ix1: Ethernet address: ac:1f:6b:8d:00:3d
ix1: netmap queues/slots: TX 8/2048, RX 8/2048
ix1: Unsupported SFP+ module type was detected.
ix1: link state changed to UP

In /boot/loader.conf.local I have added:

hw.ix.unsupported_sfp="1"
hw.ixgbe.unsupported_sfp="1"

In the System Tunables I have added

hw.ix.unsupported_sfp
hw.ixgbe.unsupported_sfp
Both with value = 1

Any suggestions or other things I should add to this bugreport?

History

#1 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Not a Bug
  • Priority changed from Urgent to Normal

This seems more like a configuration issue, such as not having a high enough mbuf allocation setup.

Please post to the forum at https://forum.netgate.com for assistance, and you might also drop a line to support at https://go.netgate.com

Also available in: Atom PDF