Project

General

Profile

Bug #9479

Alias table not updated when adding new entry

Added by Vladimir Lind 3 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Rules/NAT
Target version:
-
Start date:
04/17/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4_2
Affected Architecture:

Description

On 2.4.4-p2 CE and arm - tested on MBT2220 and SG3100:

I can't replicate it every time - I would say the majority of the times alias table gets updated properly - but in a significant part of cases alias table (IP's) entry addition is not reflected in:

pfctl -t <AliasName> -T show

So this entry doesn't work though I can see new entry in firewall rules when point to the alias.
If I add entry using pfctl:

pfctl -t CustomerSystems -T add <IP>

Entry is effectively added.

Other workaround is just to reboot the system.

History

#1 Updated by Jim Pingle 3 months ago

Does the alias contain any FQDNs? Or only IP addresses and subnets? If it contains FQDNs, this may be a duplicate of #9296

#2 Updated by Vladimir Lind 3 months ago

Yes, it does contain a couple of FQDNs in both cases.

#3 Updated by Jim Pingle 3 months ago

Try to replicate without the FQDNs. If the issue doesn't happen, then this can be closed in favor of the earlier ticket.

#4 Updated by Vladimir Lind 3 months ago

Removed FQDN's - it didn't happen. Looks 9296 related.

#5 Updated by Jim Pingle 3 months ago

  • Status changed from New to Duplicate
  • Target version deleted (2.5.0)

Also available in: Atom PDF