Project

General

Profile

Bug #9604

FRR cannot redistribute route to OpenVPN network

Added by Steven Perreau 24 days ago. Updated 23 days ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/27/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.4-p3
Affected Architecture:

Description

FRR will not redistribute the exact route to a local OpenVPN network as either;
  • A sub network selecting the OpenVPN interface under "Services > FRR > OSPF > OSPF Interfaces"
  • A Zebra/FRR global static router under "Services > FRR > Global Settings"

The only way to redistribute the local OpenVPN network is redistribute the Kernel routing table (messy and needs lot of route pruning)
or
Redistribute a supernet as a static route (not alway possible perhaps due to adjacent networks and not ideal)

More information:
[[https://forum.netgate.com/topic/144153/frr-ospf-distribute-route-for-openvpn-interface]]

History

#1 Updated by Jim Pingle 23 days ago

  • Status changed from New to Not a Bug

This isn't a bug we can fix, it's how FRR behaves on point-to-point links. The other attempts you made to get a route in there aren't correct, either, but I'll respond on the thread with why.

Also available in: Atom PDF