Project

General

Profile

Bug #9623

IPv6 Default gateway uses parent nic of PPPOE interface

Added by James Tandy about 2 months ago. Updated 10 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Gateways
Target version:
-
Start date:
07/09/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:

Description

Setup:
WAN - IPv4 PPPoE via re1, IPv6 via SLAAC.

Expected result: Stable IPv6 connectivity

Actual result:
When booting, pfsense brings up PPPoE wan, using pppoe1.
ipv6 RA is recieved from ISP.
IPv6 Default gateway is then set to fe80::f2f7:55ff:fe55:d300%re1

The problem here is the %re1 - this is the parent interface, and not the PPPoE link.
While this is in use as default gateway, there is no WAN or LAN ipv6 connectivity.

Solution:
SSH to pfsense
route del -inet6 default
route add -inet6 default fe80::f2f7:55ff:fe55:d300%pppoe1

This solution is only temporary until either a new RA is recieved, or the system reboots, or the PPPoE link reconnects.

This has happened since around 2.2 era, on all types of hardware.

History

#1 Updated by Jim Pingle 10 days ago

  • Status changed from New to Duplicate

Duplicate of #9324

Also available in: Atom PDF