Project

General

Profile

Bug #9689

DHCP server should be able to advertise interface IP automatically even with alternative DNS service

Added by Alfred Barnat 12 months ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
DHCP Server
Target version:
-
Start date:
08/19/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

The text below the "DNS servers" fields on the DHCP server configuration reads "Leave blank to use the system default DNS servers: this interface's IP if DNS Forwarder or Resolver is enabled, otherwise the servers configured on the System / General Setup page.".

This is limiting, when using an alternative DNS service (such as the BIND package), especially for IPv6 where IPs are likely not to be static. There should be a way to access the later part of this functionality, advertising the interface IP as the DNS server, even without the DNS forwarder or resolver packages enabled.

The request is for a checkbox to tell the DHCP server to advertise an interface's IP address as the DNS server rather than defaulting to the servers configured on the System / General Setup page, as the servers used by the router for DNS resolution may well not be what you want to advertise to clients. This does not require any knowledge of the fact that a DNS server is or is not running on the interface; if one isn't, then DNS resolution will simply be broken for DHCP clients until the admin fixes the misconfiguration.

History

#1 Updated by Jim Pingle 12 months ago

  • Status changed from New to Duplicate

Duplicate of #8234

Making a new issue doesn't change the previous comments.

#2 Updated by Alfred Barnat 12 months ago

The comments did not accurately reflect the feature request, and once rejected, experience suggested the issue would not be looked at again.

The request here is just to be able to enable the existing behavior even if the built-in DNS server is not enabled; essentially, an option to say "Yes, I do have a DNS server running on this interface, even though you don't know about it.". This is a very useful behavior needlessly tied to the enablement of the built-in DNS server.

Also available in: Atom PDF