Project

General

Profile

Actions

Feature #9757

closed

DH groups 25,26,27 not listed for phase1 & phase2

Added by Viktor Gurov about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
09/13/2019
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

groups 25 (ecp192), 26 (ecp224) and 27 (ecp224bp) is in list of supported by strongswan:

# ipsec listalgs | grep ECP
  dh-group:   ECP_256[openssl] ECP_384[openssl] ECP_521[openssl] ECP_224[openssl] ECP_192[openssl] ECP_256_BP[openssl]
              ECP_384_BP[openssl] ECP_512_BP[openssl] ECP_224_BP[openssl] MODP_3072[openssl] MODP_4096[openssl]

but not listed in DH Group / PFS selection menu

2.5.0-DEVELOPMENT (amd64)
built on Thu Sep 12 23:59:20 EDT 2019
FreeBSD 12.0-RELEASE-p10

Actions #1

Updated by Jim Pingle about 2 years ago

  • Tracker changed from Bug to Feature
  • Target version set to 2.5.0
  • Affected Version deleted (2.5.0)

Not a bug, but a missing feature.

Actions #2

Updated by Jim Pingle about 2 years ago

Added them in and tried 26. Showed as working and in-use on both ends, so it looks OK, no extra plugins to enable or anything fancy needed.

Commit coming momentarily.

Actions #3

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Viktor Gurov about 2 years ago

Jim Pingle wrote:

Applied in changeset 21bee0287caf76bb7ab63ec29b0ecf7435940a06.

it's ok now
Resolved

Actions #5

Updated by Jim Pingle about 2 years ago

  • Status changed from Feedback to Resolved
Actions #6

Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.5.0 to 2.4.5
Actions #7

Updated by Jim Pingle almost 2 years ago

  • Status changed from Resolved to Feedback

Needs checked and/or tested again on 2.4.5 snapshots

Actions #8

Updated by Anonymous almost 2 years ago

  • Status changed from Feedback to Resolved

tested on 2.4.5 gitsync'd to RELENG_2_4_5, works as expected.

Actions #9

Updated by Jim Pingle almost 2 years ago

  • Assignee set to Jim Pingle
Actions

Also available in: Atom PDF