Project

General

Profile

Bug #9978

Error on XML while updating pfsense from multiple sources

Added by Andres Noriega 7 months ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
12/17/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

While adding rules, editing alias, NAT, Packages.. etc. from different computers at the same time a bug comes up, rules or aliases change their position.
once Save button is clicked on computer number 1 information changes on the XML which till this point it is ok, but if another user
was editing an alias or a rule at the same time and hits Save a few moments later, the information tends to be corrupted, saved in a totally different alias, or simply does not saves
which causes a complications when 2 or more admins are working on the firewall

This behaviour can be reproduced by editing/creating editing/editing 2 aliases or more at the same time by different users, also adding NAT or firewall rules causes the same issue

History

#1 Updated by Jim Pingle 7 months ago

  • Category changed from XML Parser to Web Interface
  • Status changed from New to Duplicate
  • Affected Version deleted (2.4.4-p3)
  • Affected Architecture added
  • Affected Architecture deleted (amd64)

Duplicate of #8285

Also available in: Atom PDF