Project

General

Profile

Bug #1007

captive portal fatal error

Added by Dan Emmons almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Captive Portal
Target version:
Start date:
11/12/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

running build pfSense-2.0-BETA4-20101111-2203 x86

Configured pfsense for Captive Portal with DNS forward and no user Auth.

Basic routing and dns settings, no other changes.

Once I click through the Captive Portal splash page, I get:

"Fatal error: Call to undefined function display_error_form() in /etc/inc/auth.inc on line 109"

Looking at /etc/inc/auth.inc, lines 109-112 are:

display_error_form("501", "An HTTP_REFERER was detected
other than what is defined in System -> Advanced (" . $_SERVER['HTTP_REFERER'] .
"). You can disable this check if needed in System -> Advanced -> Admin.");
exit;

I tried disabling the HTTP_REFERER under advanced options, as well as the http redirect.

Still getting the error.

Associated revisions

Revision 0aa72c10 (diff)
Added by Erik Fonnesbeck almost 9 years ago

Don't perform referer check if display_error_form is not defined (captive portal), just like as is done for the DNS rebind check. Ticket #1007

History

#1 Updated by Dan Emmons almost 9 years ago

I'm not trying to open a page with any form of redirect, just google.com or a blank "test" page on a remote httpd.

#2 Updated by Chris Buechler almost 9 years ago

  • Category set to Captive Portal
  • Target version set to 2.0
  • Affected Version set to 2.0

#3 Updated by Erik Fonnesbeck almost 9 years ago

  • Status changed from New to Feedback

I've committed a check like what is done before the DNS rebind checks. With the change it should prevent the code giving the error from running. The captive portal probably shouldn't have a referrer check anyway, because you can get there from anything.

#4 Updated by Jon Bruce almost 9 years ago

Not seen in Mon Nov 15 17:03:26 EST 2010 firmware version. Same basic setup running, no errors.

#5 Updated by Ermal Lu├ži almost 9 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF