Project

General

Profile

Bug #1039

Error on Syncronisation slave - DIOCADDRULE: Device busy

Added by Martin Klein over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/24/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

On 10 - 30 % of config synchronisations to a slave machine we
get a notification from the slave:

There were error(s) loading the rules: pfctl: DIOCADDRULE: Device busy The line in question reads [ DIOCADDRULE]:

Here are the log entries:

Nov 24 18:46:28 gwb php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'pfctl: DIOCADDRULE: Device busy' 
Nov 24 18:46:28 gwb php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'pfctl: DIOCADDRULE: Device busy'
Nov 24 18:46:28 gwb php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'pfctl: DIOCADDRULE: Device busy'
Nov 24 18:46:28 gwb php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'pfctl: DIOCADDRULE: Device busy'
Nov 24 18:46:28 gwb php: : New alert found: There were error(s) loading the rules: pfctl: DIOCADDRULE: Device busy The line in question reads [ DIOCADDRULE]:
Nov 24 18:46:28 gwb php: : New alert found: There were error(s) loading the rules: pfctl: DIOCADDRULE: Device busy The line in question reads [ DIOCADDRULE]:
Nov 24 18:46:28 gwb php: : Message sent to OK
Nov 24 18:46:28 gwb php: : Message sent to OK
Nov 24 18:46:28 gwb php: : There were error(s) loading the rules: pfctl: DIOCADDRULE: Device busy - The line in question reads [ DIOCADDRULE]:
Nov 24 18:46:28 gwb php: : There were error(s) loading the rules: pfctl: DIOCADDRULE: Device busy - The line in question reads [ DIOCADDRULE]:

History

#1 Updated by Chris Buechler over 8 years ago

  • Affected Version set to 2.0

#2 Updated by Ermal Luçi over 8 years ago

  • Status changed from New to Feedback

Possible fix committed.

#3 Updated by Martin Klein over 8 years ago

I am sorry to say but on a Tue Nov 30 02:04:03 EST 2010
Snapshot the problem is not fixed.

#4 Updated by Ermal Luçi over 8 years ago

By any chance you have services like uPNP running?

#5 Updated by Martin Klein over 8 years ago

We are not running uPNP.

We have a few filter and nat rules
and we are running the following services:

carp (5 Interfaces)
dnsmasq
ntpd
dhcpd
bsnmpd
openvpn

#6 Updated by Ermal Luçi over 8 years ago

Please update to newer snapshots.
This should be fixed now.

#7 Updated by Martin Klein over 8 years ago

On the Dec 7 snapshot
the problem seems to be fixed.

Thank You

#8 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

thanks

Also available in: Atom PDF