Project

General

Profile

Feature #10392

GRE: Tunnels cannot have IPv6 and IPv4 addresses at the same time

Added by Skyler Mäntysaari 6 months ago. Updated 12 days ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
03/30/2020
Due date:
% Done:

100%

Estimated time:

Description

For some unknown reason, pfSense does not ask in the GUI for local/remote IPv6 addresses when a user wants to use it to carry both, this is defined in [[https://tools.ietf.org/html/rfc7676]].

This should be addressed.

Associated revisions

Revision 5cb09a31 (diff)
Added by sebastian nielsen 5 months ago

Feature #10392: GRE: Tunnels cannot have IPv6 and IPv4 addresses at the same time

Revision e8e3fd22 (diff)
Added by sebastian nielsen 5 months ago

Feature #10392: Removed IPv4/IPv6 selection. Added code for configuration migration on upgrade.

Revision 491217a6 (diff)
Added by sebastian nielsen 5 months ago

Feature #10392: Improved/unified wording, removed link3, fixed empty() vs !== bug, fixed upgrade code. Increased config to 20.3.

History

#1 Updated by Skyler Mäntysaari 6 months ago

Skyler Mäntysaari wrote:

For some unknown reason, pfSense does not ask in the GUI for local/remote IPv6 addresses when a user wants to use it to carry both, this is defined in https://tools.ietf.org/html/rfc7676.

This should be addressed.

#2 Updated by Jim Pingle 6 months ago

  • Category set to Interfaces

It may be in the RFC but have you confirmed that it actually works on FreeBSD?

#3 Updated by Sebas tian 5 months ago

I manually executed

/sbin/ifconfig gre0 inet6 <localV6> <remoteV6> prefixlen 128
(as etc/inc/interfaces.inc would do it) and I can (at least) ping the tunnel remote now, so it seems to works? Although pfSense seems to remove the v6 address shortly after manually setting it …

#4 Updated by Jim Pingle 5 months ago

In that case it should be fairly easy to add that to the GUI by splitting it into separate IPv4 and IPv6 options. It will need some upgrade code to separate out the existing IPv4 and IPv6 config into the new fields but that should be simple.

The same should be done to GIF as well

#5 Updated by Sebas tian 5 months ago

I have implemented the necessary changes for GRE interfaces (and tested them with my setup – seems to be working). I have no way of testing it for GIF and therefore hesitate to add my changes there, too. Should I still do it nevertheless or should I just create a PR for the GRE part? (PRs on Github are the correct way to submit the changes, right?)

#6 Updated by Sebas tian 5 months ago

#7 Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review

#8 Updated by Jim Pingle 5 months ago

  • Target version set to 2.5.0

#9 Updated by Renato Botelho 4 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#10 Updated by Viktor Gurov 12 days ago

  • Status changed from Feedback to Resolved

tested on two 2.5.0.a.20200916.1850
works as expected:

gre0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1476
    description: GRE
    options=80000<LINKSTATE>
    tunnel inet 192.168.88.41 --> 192.168.88.42
    inet 10.88.88.41 --> 10.88.88.42 netmask 0xffffff00
    inet6 fe80::2ce7:6345:e2a8:cd6c%gre0 prefixlen 64 scopeid 0xa
    inet6 fc00:88::41 --> fc00:88::42 prefixlen 128
    groups: gre
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

Resolved

Also available in: Atom PDF