Project

General

Profile

Bug #10566

password for OpenDNS (under DynDNS) not being passed correctly

Added by Frank Graffagnino 5 months ago. Updated 13 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
05/18/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5
Affected Architecture:

Description

When utilizing the dynDNS service to update a WAN IP on the OpenDNS, the password was not accepted even though it was entered correctly. This was in 2.4.5.

Steps to reproduce:
- Create an account on OpenDNS using a password with an ampersand (&) in it.
- Set up a dynamic dns entry in pfsense using opendns with the same login and password and the network name as the "domain" in pfsense
- enable verbose logging
- save and force update
- observer in system log errors about password not being accepted on openDNS

To workaround
- change the password on the openDNS account to use a dollar-sign ($) instead of ampersand (&)
- update the dynamic dns entry in pfsense for openDNS to use the new password
- save and force update
- observer that IP is now green and log shows successful login

History

#1 Updated by Jim Pingle 5 months ago

  • Category set to Dynamic DNS

Does it work if you put the password in with the & changed to &?

Change this:

abc&123

To this:

abc&123

#2 Updated by Marcos Mendoza 13 days ago

I was able to reproduce this on 2.5.0.

Changing the password character from & to & when entering it in the field resulted in the same invalid password message in the system logs.

#3 Updated by Marcos Mendoza 13 days ago

Tested this directly on the browser by using:
https://updates.opendns.com/nic/update?hostname=myhostname

I experienced the same issue there which indicates a bug with OpenDNS' update API. I searched their KB and this seems to be a known issue - see screenshot.

Also available in: Atom PDF