Project

General

Profile

Actions

Bug #10629

closed

miniupnp failed to migrate interface

Added by Tom Cosmos over 1 year ago. Updated over 1 year ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
UPnP/NAT-PMP
Target version:
-
Start date:
06/03/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:
amd64

Description

I recently went through a backup/restore to a new device (newer hardware, more interfaces, etc). My design, for conversation purposes, is a router on a stick. Originally all VLANs were attached to a LAGG, including the WAN interface (VLAN 5). After getting the new device up, I moved the WAN interface to a dedicated port, igb0. It seems that the change in the GUI was fine for miniupnp (as it only references the interface "WAN"), but in the configuration file (and the logs) it did not update properly. This was spamming in the logs:
Jun 3 10:46:40 miniupnpd 16528 Failed to get ip address for interface lagg0.5
Jun 3 10:46:40 miniupnpd 16528 ioctl(s, SIOCGIFADDR, ...): Can't assign requested address
Jun 3 10:31:40 miniupnpd 16528 Failed to get ip address for interface lagg0.5
Jun 3 10:31:40 miniupnpd 16528 ioctl(s, SIOCGIFADDR, ...): Can't assign requested address
Jun 3 10:16:40 miniupnpd 16528 Failed to get ip address for interface lagg0.5
Jun 3 10:16:40 miniupnpd 16528 ioctl(s, SIOCGIFADDR, ...): Can't assign requested address
Jun 3 10:01:40 miniupnpd 16528 Failed to get ip address for interface lagg0.5

In order to force it over, I had to assign the interface to something else, then assign it back.

I'm not really sure what I could have done different, but I did notice that miniupnpd.conf references physical interfaces, not the logical ones, which may have been the issue, as WAN was always the External Interface, but not always ext_ifname.
Before:
ext_ifname=lagg0.5
listening_ip=lagg0.100
listening_ip=lagg0.200
listening_ip=lagg0.600
listening_ip=lagg0.300

After:
ext_ifname=igb0
listening_ip=lagg0.100
listening_ip=lagg0.200
listening_ip=lagg0.600
listening_ip=lagg0.300

Actions #1

Updated by Jim Pingle over 1 year ago

  • Category set to UPnP/NAT-PMP
  • Status changed from New to Not a Bug

There isn't a problem with miniupnpd that I can see here. It had to have been elsewhere in your configuration.

The UPnP config only references the internal name (like "wan" or "opt1"). Depending on how you reassigned your interfaces, something else must have been missed in your process. Especially if you edited the interfaces manually vs doing it in the GUI.

This site is not for support or diagnostic discussion, however, so figuring out what might have been wrong in your process is out of scope here. Start a forum thread at on the Netgate Forum and if an actionable bug can be identified, we can open a new issue with a more accurate description and details.

Actions #2

Updated by Tom Cosmos over 1 year ago

Jim Pingle wrote:

There isn't a problem with miniupnpd that I can see here. It had to have been elsewhere in your configuration.

The UPnP config only references the internal name (like "wan" or "opt1"). Depending on how you reassigned your interfaces, something else must have been missed in your process. Especially if you edited the interfaces manually vs doing it in the GUI.

This site is not for support or diagnostic discussion, however, so figuring out what might have been wrong in your process is out of scope here. Start a forum thread at on the Netgate Forum and if an actionable bug can be identified, we can open a new issue with a more accurate description and details.

I did not edit the file by hand, I was only referencing it. The change of the WAN interface was in the GUI. The only thing I did was change the WAN interface from a VLAN interface to a physical one.
Not looking for support, issue is gone, just reporting what I saw.

Actions

Also available in: Atom PDF